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Introduction

he power of Python. The Python language is becoming more and more pop-
ular, and in 2017 it became the most popular language in the world accord-
ing to IEEE Spectrum. The power of Python is real.

Why is Python the number one language? Because it is incredibly easy to learn
and use. Part of it is its simplified syntax and its natural-language flow, but a lot
of it has to do with the amazing user community and the breadth of applications
available.

About This Book

This book is a reference manual to guide you through the process of learning
Python and how to use it in modern computer applications, such as data science,
artificial intelligence, physical computing, and robotics. If you are looking to learn
a little about a lot of exciting things, then this is the book for you. It gives you an
introduction to the topics that you will need to go deeper into any of these areas
of technology.

This book guides you through the Python language and then it takes you on a tour
through some really cool libraries and technologies (the Raspberry Pi, robotics, Al,
data science, and so on) all revolving around the Python language. When you work
on new projects and new technologies, Python is there for you with an incredibly
diverse number of libraries just waiting for you to use.

This is a hands-on book. There are examples and code all throughout the book.
You are expected to take the code, run it, and then modify it to do what you want.
You don’t just buy a robot, you build it so you can understand all the pieces and
can make sense of the way Python works with the robot to control all the motors
and sensors. Artificial intelligence is complicated, but Python helps make a sig-
nificant part of it accessible. Data science is complicated, but Python helps you do
data science more easily. Robotics is complicated, but Python gives you the code
that controls the robot. And Python even allows us to tie these pieces together and
use, say, Al in robotics.

In this book, we take you through the basics of the Python language in small,
easy-to-understand steps. After we have introduced you to the language, then we
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step into the world of Python and artificial intelligence, exploring programming
in machine learning and neural networks using Python and TensorFlow and actu-
ally working on real problems and real software, not just toy applications.

After that, we’re off to the exciting world of Big Data and data science with Python.
We look at big public data sets such as medical and environmental data all using
Python.

Finally, you get to experience the magic of what I call “physical computing.”
Using the small, inexpensive Raspberry Pi computer (it’s small, but incredibly
popular) we show you how to use Python to control motors and read sensors. This
is a lead-up to our final book, “Python and Robotics.” Here you learn how to build
a robot and how to control that robot with Python and your own programs, even
using artificial intelligence.

This is not your mother’s RC car.
Python data science, robotics, Al, and fun all in the same book.

This book won’t make you understand everything about these fields, but it will
give you a great introduction to the terminology and the power of Python in all
these fields. Enjoy the book and go forth and learn more afterwards.

Foolish Assumptions

We assume you know how to use a computer in a very basic way. If you can turn on
the computer and use a mouse, you’re ready for this book. We assume you don’t
know how to program yet, although you will have some skills in programming
by the end of the book. If we’re wrong and you do already know Python (or some
other computer language), jump ahead to minibook 4 and dig right into learning
something new. Our intent is to guide you through the language of Python and
then through some of the amazing technologies and devices that use Python. We
provide complete examples. If you get stuck on something, look it up on the web,
read a tutorial, and then come back to it.

Icons Used in This Book

What’s a For Dummies book without icons pointing you in the direction of truly
helpful information that’s sure to speed you along your way? Here we briefly
describe each icon we use in this book.
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Chapter 1
Starting with Python

he fact that you’re reading this implies you know that Python is a great

thing to know if you’re looking for a good job in programming. It’s also

good to know if you’re looking to expand your existing programming skills
into exciting cutting-edge technologies like artificial intelligence (AI), machine
learning (ML), data science, or robotics, or even if you’re just building apps in
general. So we’re not going to try to sell you on Python. It sells itself.

Our approach, especially in this book, leans heavily toward the hands-on. A com-
mon failure in many tutorials is that they already assume you’re a professional
programmer in Python or some other language, and they skip over things they
assume you already know.

This book is different in that we don’t assume you’re already programming in
Python or some other language. We assume you can use a computer and under-
stand basics like files and folders. But that’s about it for assumptions.

We also assume you’re not up for settling down in an easy chair in front of the
fireplace to read page after page of theoretical stuff “about” Python, like some
kind of novel. You don’t have that much free time to kill. So we’re going to get
right into it and focus on doing, hands-on, because that’s the only way most of us
learn. Personally, we’ve never seen anybody read a book “about” Python and then
sit at a computer and write Python like a pro. Human brains don’t work that way.
We learn through practice and repetition, and that requires hands-on.

CHAPTER 1 Starting with Python 7



Why Python Is Hot

We promised we weren’t going to spend a bunch of time trying to “sell” you on
Python, and that’s not our intent here. Python is hot — that’s probably why you want
to learn it, and that’s good. But we would like to talk briefly about why it’s so hot.

Python is hot primarily because it has all the right stuff for the kind of soft-
ware development that’s really driving the whole software development world
these days. Machine learning, robotics, artificial intelligence, and data science are
the leading technologies today and for the foreseeable future. Python is popular
mainly because it already has lots of capabilities in those areas, while many older
languages lag behind in these technologies.

If you’re not familiar with programming languages like C and Java, feel free to
skip to the next section, “Python versions,” as this information is only for people
who wonder about differences among the languages. But in case you’re wonder-
ing, just as there are different brands of toothpaste, shampoo, cars, and just about
every other product you can buy, there are different “brands” of programming
languages with names like Java, C, C++ (pronounced C plus plus), and C# (pronounced
C sharp). They’re all programming languages, just like all brands of toothpaste are
toothpaste. The main reasons cited for Python’s current popularity are

¥ Python is relatively easy to learn.
¥ Everything you need to learn (and do) Python is free.

¥ Python offers more readymade tools for current hot technologies like data
science, machine learning, artificial intelligence, and robotics than most other
languages.

HTML, CSS, AND JavaScript

Some of you may have heard of languages like HTML, CSS and JavaScript. Those aren't
traditional programming languages for developing apps or other generic software.
HTML and CSS are specialized for developing Web pages. JavaScript is a programming
language; however, it too is heavily geared to Website development and isn't quite in
the same category of general programming languages like Python and Java.

Another way to look at it is, you wouldn't learn HTML, CSS, and JavaScript instead of

Python, as there is too little overlap to justify it. If you specifically want to design and
create websites, you have to learn HTML, CSS, and JavaScript whether you're already
familiar with Python or some other programming language.

8 BOOK1 Getting Started with Python









If you paid close attention you may notice that Version 3.0 starts in December
2008, but Version 2.7 extends into 2010. So if versions are like car years, why the
overlap?

The car years analogy is just an analogy indicating that the larger the number,
the more recent the version. But in Python it’s the most recent within the main
Python version. When the first number changes, that’s usually a change that’s so
significant, software written in prior versions may not even work in that version.
If you happen to be a software company with a product, written in Python 2, on
the market, and have millions of dollars invested in that product, you may not
be too thrilled to have to start over from scratch to go with the current version.
So “older versions” often continue to be supported and evolve, independent of the
most recent version, to support developers and businesses that are already heavily
invested in the previous version.

The biggest question on most beginners minds is “what version should I learn?”
The answer to that is simple . . . whatever is the most current version. You'll know
what that is because when you go to the Python.org website to download Python,
they will tell you what the most current stable build (version) is. That’s the one
they’ll recommend, and that’s the one you should use.

The only reason to learn something like Version 2 or 2.7 or something else older
would be if you’ve already been hired to work on some project, and that company
requires you to learn and use a specific version. That sort of thing is rare, because
as a beginner you’re not likely to already have a full-time job as a programmer.
But in the messy real world there are companies heavily invested in some earlier
version of a product, so when hiring, they’ll be looking for people with knowledge
of that version.

In this book, we focus on versions of Python that are current in late 2018 and early
2019, from Python 3.7 and above. Don’t worry about version differences after the
first and second digits. Version 3.7.2 is similar enough go version 3.7.1 that it’s
not important, especially to a beginner. Likewise, Version 3.8 isn’t that big a jump
from 3.7. So don’t worry about these miner version differences when first learn-
ing. Most of what’s in Python is the across all versions. So you need not worry
about investing time in learning a version that’s obsolete or soon will be — unless
you happen to be learning from a very old book.

Tools for Success

Now, we need to start getting your computer set up so you can learn, and do,
Python hands-on. For one, you’ll need a good Python interpreter and editor. The
editor lets you type the code, the interpreter lets you run that code. When you run

CHAPTER 1 Starting with Python 11
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(or execute) code, you're telling the computer to “do whatever my code tells you
to do.”

The term code refers to anything written in a programming language to provide
instructions to a computer. The term coding is often used to describe the act or
writing code. A code editor is an app that lets you type code, in much the same way
an app like Word or Pages helps you type regular plain-English text.

Just as there are many brands of toothpaste, soap, and shampoo in the worlds,
there are many “brands” of code editors that work well with Python. There isn’t
a right one or wrong one, a good one or bad one, a best one or worst one. Just a
lot of different products that basically do the same thing but vary slightly in their
approach and what that editor’s creators thing is “good.”

If you already started learning Python on your own before this book, and are
happy with whatever you’ve been using, you’re welcome to continue using that
and ignore our suggestions. If you're just getting started with this stuff, we sug-
gest you use VS Code, because it is. ..

An excellent, free learning environment

The editor we recommend, and will be using in this book, is called Visual Studio
Code, officially. But most often you hear is spoken or written as VS Code. The main
reasons it’s our own favorite are as follows:

¥ Itis an excellent editor for learning coding.

¥ lItis an excellent editor for writing code professionally, and is in fact used by
millions or professional programmers and developers.

¥ It's relatively easy to learn and use.
¥ It works pretty much the same on Windows, Mac, and Linux.

» It'sfree.

The editor is an important part of learning and doing Python code. But you also
need the Python interpreter. Chances are, you’re also going to want some Python
packages, too. The packages are simply code already written by someone else to do
common tasks so that you don’t have to start from scratch and reinvent the wheel
every time you want to perform one of those tasks.

Python packages are not a “crutch” for beginners. They are major components
of the entire Python development environment and are used by seasoned profes-
sionals as much as they are used by beginners.
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FIGURE 1-2:

Click Download
under the largest
version number.
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{) ANACONDA Wt e Anaconae? Broducts Summort

Anaconda 5.3 For Windows Installer

Python 3.7 version * Python 2.7 version *

& Download & Download

Behind a firewall?
How o get Python 36 or other Python versions
How to Install ANACONDA

Click Download under whichever version number is the highest on your
screen.

For me, right now, it's version 3.7 but a higher-numbered version may be
available when you get there. Don’t worry about that.

Jot down the Python version number you're downloading for future reference
a little later in this chapter. You can also click How to Install ANACONDA on the
download page if you'd like to see the instructions from the Anaconda team.

If prompted for your email address, either provide it or click the X in the
pop-up window's upper-right corner to close the prompt without entering
your email address.

If you see Keep/Discard options in the lower-left corner of your screen,
click Keep.

When the download is complete, open your Downloads folder (or
whichever folder to which you downloaded the file).

If you're using Mac or Linux, double-click the file you downloaded. If
you're using Windows, right-click that file and choose Run as
Administrator, as shown in Figure 1-3.

The Run-As-Administrator business in Windows ensures that you can install
everything. If that option isn't available to you, double-clicking the file's icon
should be sufficient.

Click Next, Continue, Agree, or | Agree on the first installation pages until
you get to one of the pages shown in Figures 1-4 (Mac will be on the one
on the left, Windows the one on the right).
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FIGURE 1-3:
In Windows,
right-click and
choose Run As
Administrator.

FIGURE 1-4:
Choose how to
install Anaconda.

Q

TIP

G Run as administrator
)q Open with Code

Anaconda3-5.3.0
-Windows-x86_6 Troubleshoot compatibility

dexe Pin to Start
[2f Edit with Notepad++
E3 scan with Windows Defender...
& Share

Anaconda2 5.2.0 (64-bit) Setup

Select Installation Type
ANACONDA  please select the type of installation you would like to perform for

Anaconda3 5.3.0 (64-bit). o ‘e Install Anaconda3

Select a Destination

Install for:
Intreduction How do you want to install this software?
(O Just Me (recommended) Read Me

@Al Users (requires admin priviieges}; License

Destination Select

Installation Type i Install for me only
Installation
Microsoft VSCode ‘ Install on a specific disk...

Summary

<o

J Installing this software requires 2.2 GB of space.

You have chosen to install this software in your home folder.
Only the current user will be able to use this software.

ANACONDA

Go Back Continue

9. Choose whichever option makes sense to you. Or, if in double, choose
Install on a specific disk (for Mac), and then Macintosh HD, or choose
Install for All Users (if on Windows using Administrator privileges. If the
option we suggested isn’t available to you, click the one closest to it.

10. click continue or Next and follow the onscreen instructions. If you're
unsure about what options to choose on any page, don't choose any. Just
accept the default suggestions.

1.1t may take several minutes, but eventually you'll come to a page where
it asks if you want to installed Microsoft VS Code. Click Install Microsoft
VS Code (or whatever option on your screen indicates that you want to
install VS Code).

If VS Code is already installed on your computer, no worries. The Anaconda
installer will just tell you that, or perhaps update your version to the more
current version.

1 2 Continue to follow any onscreen instructions, click Continue or Next to
proceed through the installation steps, then click Close or Finish on the
last page.

CHAPTER 1 Starting with Python
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You may be prompted to sign up with Anaconda Cloud. Doing so is free, but not
required. So you can decide for yourself if that’s something you want to do.

Opening Anaconda (Mac)

After it’s installed on your Mac, you can open Anaconda as you would any other
app. Use whichever of the following methods appeals to you:

3 Open Launchpad and open Anaconda Navigator.

¥ Or click the Spotlight magnifying glass, start typing Anaconda, and then
double-click Anaconda Navigator.

3 Or open Finder and your Applications folder and double-click the Anaconda-
Navigator icon there.

After Anaconda Navigator opens, right-click its icon in the Dock and choose Keep
in Dock to keep its icon visible in the Dock at all times so it’s easy to find when
you need it.

Opening Anaconda (Windows)

After Anaconda is installed in Windows, you can start it as you would any other
app. Although there are some differences among different versions of Windows,
you should be able to use just about any of these options:

¥ Click the Start button then click Anaconda Navigator on the Start menu.

3 Or click the Start button, start typing Anaconda, then click Anaconda-
Navigator on the Start menu once you see it there.

On the Start menu you can right-click Anaconda-Navigator and choose Pin to
Start or right-click and choose More= Pin to Taskbar to make the icon easy to
find in the future.

Using Anaconda Navigator

Anaconda Navigator, as the name implies, is the component of the Anaconda
environment that lets you navigate around through different features of the app
and choose what you want to run. When you first start it, it open to the Anaconda
Navigator home page, which should look something like Figure 1-5.

If you see a prompt for getting an updated version when you open Anaconda, it’s
okay to install the update. It won’t cost anything or affect your ability to follow
along in this book.

BOOK 1 Getting Started with Python



FIGURE 1-5:
Anaconda
Navigator
Home page.

‘) ANACONDA NAVIGATOR Signed inas Alentimsesn
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St fthon Development
. p——
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o
Streamiinesc
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Dscumentztion 35 running snd version control
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- .
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Down the left side of the Anaconda Navigator home page you see options like
Home, Environments, Learning, Community, Documentation, and Developer
Blog. You’re welcome to explore these on your own. However, they’re not directly
related to learning and doing Python, so we’ll let you choose which of those, if
any, you’re interested in exploring.

Writing Python in VS Code

Most of the Python coding we do here, we’ll do in VS Code. Whenever you want
to use VS Code to write Python, we suggest that you open VS Code from Anaconda
Navigator, rather than from the Start menu or Launch Pad. That way VS Code will
already be “pointing to” to version of Python that comes with Anaconda, which is
easier than trying to figure out all of that yourself. So the steps are

1. you haven't already done so, open Anaconda Navigator.
2. if necessary, scroll down a little until you see the Launch button under VS Code,

then click the Launch button.

The very first time you open VS Code you may be prompted to make some deci-
sions. None of the suggested are required, so you can just click the X in the upper-
right corner of the each one. Note, however, the one that mentions Git will keep
popping up at you unless you click Don’t Show Again.

CHAPTER 1 Starting with Python 17
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FIGURE 1-6:

VS Code editor
with welcome
screen.

ABOUT GIT

Git is a popular means of storing backups of your coding projects, and sharing coding
projects with other developers or team members. It's popular with professional pro-
grammers and VS Code has built-in support for it. But Git is entirely optional and not
directly related to learning or doing Python coding. So it's perfectly okay to choose Don't
Show Again to bypass that offer when it arrives. You can install Git at any time in the
future if you later decide to learn about it.

When you’re finished, the VS Code window will look something like Figure 1-6.

If you don’t see quite that many options on your screen, choose Help=>Welcome
from the menu bar.

4] File Edit Selection View Go Debug Terminal Help Welcome - Visual Studio Code - [m] *
@ EXPLORER ) welcome % m -
4 OPEN EDITORS
p % 2] Welcome Customize
4 NO FOLDER OPENED
Rl  You have not yet opened a folder.
9 Open Folder
l Settings and keybindings
nstall the settings and keyboard shortcuts of Vim, S..
[ et
ol
code look the way you love
Learn
Find and run all comma
Rapidly access and mands from the Com...
@ Show welcome page on startup
b OUTLINE

Your screen will likely be black with white and colored text. In this book, we show
everything as white with black text because it’s easier to read on paper that way.
You can keep the dark background if you like. If you would rather have a light
background, on a Mac click Code on the menu and choose Preferences Color
Theme. In Windows, choose Filew> Preferences<> Color Theme. Then choose a
lighter color theme, like Light (Visual Studio) and your VS Code screens will look
more like the ones in this book.
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To make sure you’re ready to do Python coding, click the Extensions icons in the
left pane (it looks like a puzzle piece). You should see at least three extensions
listed, Anaconda Extension Pack, Python, and YAML, as shown in Figure 1-7.

Search Extensions in Marketplace

4 ENABLED 3
Anaconda Extension Pack 1.0.1 P17M * 5

% ’ The Anaconda Extension Pack is a set of extensions th... der
h Microsoft o)

Python z01z.10.1 452270 k45
a Linting, Debugging (multi-threaded, remote), Intellisen...
Microsoft ol
YAML Support by Red Hat o010 Gr28M K4S
0 ¥AML Support for Visual Studio Code provided by Red...
Red Hat ol

FIGURE 1-7:

VS Code
extensions |
for Python.  Extensions icon

Choosing your Python interpreter

Before you start doing any Python coding in VS Code, you want to make sure
you’re using the correct Python interpreter. Do to so, follow these steps:

1 . Choose View=> Command Palette from VS Code’s menu.

2. Type python and then click Python: Select Interpreter.

Choose the Python version number that matches your download (the one you
jotted down while first downloading Anaconda). If you have multiple options
with the same version number, choose the one that includes the names base
and conda, as in Figure 1-8.

kurrent: python

search Extensions in Mal Python 3.7.0 64-bit (‘base’: conda)

N

ENABLED

p Anaconda Extension Pack 101 G17M

% The Anaconda Extension Pack is a set of extensions th...

FIGURE 1-8: L Microsoft fol
Choose ﬂ PR

Linting, Debugging (multi-threaded, remote), Intellisen...

]

G227M 45

your Python Microsoft ol
interpreter YAML Support by Red Hat 010 zsM kas
(usually the YAML Support for Visual Studio Code provided by Red... foirecent folders
highest version fed et @
number).
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FIGURE 1-9:
Terminal in VS
Code (Windows
and Mac).

FIGURE 1-10:
Python shows
the sum of one
plus one.

Writing some Python code

To test everything to make sure it’s going to work, follow these steps:

1 . InVS Code, choose Viewc> Terminal from the VS Code menu.

You should see a pane along the bottom-right that looks like one of those
shown in Figure 1-9.

PROBLEMS ~ QUTPUT  DEBUG CONSOLE  TERMINAL 1: powershell 4+ D@ ~ O x

Windows PowerShell
Copyright {C) Microsoft Corporation. All rights reserved.

PS C:\UsersiAlan» I

0 @ a1
PROBLEMS OUTPUT  DEBUG CONSOLE  TERMINAL 1: bash s 4+ 0 O ~ O %
Alans-Air:~ alans I

| ® A

2. Inthe Terminal, type python and press Enter.

You should see some information about Python followed by a >>> prompt.
That >>> prompt is your Python interpreter; if you type Python code there and
press Enter, the code will execute.

w

Type 1+1 and press Enter.

You should now see 2 (the sum of one plus one), followed by another Python
prompt, as shown in Figure 1-10.

(base) C:\Users\Alan\OneDrive‘\AIO Python»python

Python 3.7.8 (default, Jun 28 2818, 82:84:48) [MSC v.1912 &4 bit (AMD&4)] :: Anaconda, Inc. on win32
Type "help", “"copyright", "credits" or "license" for more information.

x4l

2

e |
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The 1+1 exercise is about as simple an exercise as you can do. However, all we care
about right now is that you saw the 2, because that means your Python develop-
ment environment is all set up and ready to go. You won’t have to repeat any of
these steps in the future. Now let me show you how to exit out of Python and VS
Code. Here are the steps:

1. Inthe Vs Code Terminal pane, press CTRL+D or type exit() and press Enter.
The last prompt at the bottom of the terminal window should now be
whatever it was before you went to the Python prompt, indicating that
you're no longer in the Interpreter.

2. Toclose VS Code in Windows, click the Close (X) button in the upper-right
corner or choose View=> Exit from the menu. On a Mac, click the round
red dot in the upper-left corner, or choose Code => Quit Visual Studio Code
from the menu.

3. You can also close Anaconda Navigator using similar techniques: click the
X in the upper-right corner or choose Filec> Quit from the menu bar in
Windows. Or click the red dot or go to Anaconda Navigator in the menu
and choose Quit Anaconda-Navigator.

Getting back to VS Code Python

In the future, any time you want to work in Python in VS Code, we suggest you
open Anaconda Navigator and then Launch VS Code from there. You’ll be ready to
roll and do any of the hands-on exercises presented in future chapters.

Using Jupyter Notebook for Coding

Jupyter Notebook is another popular tool for writing Python code. The name Jupy-
ter comes from the fact that it supports writing code in three popular languages:
Julia
Python
R
Julia and R are popular for data science, Python is of course, a more generic pro-

gramming language that happens to be popular in data science as well, though
Python is good for all kinds of development, not just data science.

CHAPTER 1 Starting with Python 21
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People often use Jupyter to share code on the Internet. It’s free, and comes with
Anaconda. So if you’re installed Anaconda, you already have it and can open it at
any time by following these simple steps:

1.
2.

Open Anaconda as discussed earlier in this chapter

Click Launch under Jupyter Notebook (shown in Figure 1-11).

Anaconda Navigator

File  Help

{D ANACONDA NAVIGATOR
A Home o
‘ Environments o o
L
N8 Learning Jupyter
:J
% Community JupyterLab Notebook
A 03439 A 560

FIGURE 1-11:

An extensible environment For interactive
and reproducible computing, based on the
Jupyter Notebook and Architecture

Web-based, interactive computing
notebook envirenment. Edit and run
human-readable docs while describing the
data analysis.

Launch Jupyter
Notebook from
Anaconda’s home

page.

Jupyter notebooks are web-based, meaning that when Jupyter opens, it does
so in your default Web browser, which may be Safari, Google Chrome, Edge,
or Internet Explorer. At first, it doesn't look like it has much to do with coding,
because it just shows an alphabetized list of folder (directory) names to which
it has access, as shown in Figure 1-12. (Of course, the names you see may
different from those in the figure, because those folder names are from my
computer, not yours.)

Click a folder name of your choosing (the Desktop is fine, we're not
making any commitment here).

Click New, and then choose Python 3 under Notebook, as shown in
Figure 1-13.

A new, empty notebook named Untitled opens. You should see a rectangle
with In []: atthe left side. That's called a cell, and a cell can contain either
code (words written in the Python language) or just regular text and pictures. If
you want to write Code, make sure the drop-down menu in the toolbar shows
the word Code. You can change that to Markdown if you want to write regular
text rather than Python code.
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FIGURE 1-12:
Jupyter Notebook
opening page.

FIGURE 1-13:
Creating a new
Jupyter notebook.
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Markdown is a language for writing text that uses fonts, pictures, and such. We’ll
talk more about that in the next chapter. For now, let’s just stay focused on Python
code, since that what this book is all about.

A cell is not like the Python interpreter, where your code executes immediately.
You have to type some code first (any amount), and then run that code using the
Run button in the toolbar. To see for yourself, follow these steps:

1. clickinside the code cell.

2. Type 1+1.

3. PressEnter.

You see the 1+1 in the cell, but not result, 2. To get the result, click Run in the
toolbar or put the mouse pointer into the cell and click the Run icon at the left
side of the cell, as shown in Figure 1-14.

CHAPTER 1 Starting with Python 23

Starting with Python




 Desktop/ X | & Untitled X +
C @ localhost:3889/notebooks/Desktop/Untitled.ipynb?kermnel_name=python3
= Apps Alan Q) Alexa B, Amazon ? ampps () Anaconda 5 Blue (3 etg fb

C Ju pyter Untitled Last Checkpoint: & minutes ago (autosaved)

File Edit View Insert Cell Kemel Widgets Help
B+ = A D "*.C»Coce v [=
FIGURE 1-14: h [ ]: 141
Two ways to
run code in a
Jupyter cell.

You'll see the number 2 to the right of Out[1], as in Figure 1-15. The Out
indicates that you're seeing the output from executing the code in the cell,
which of course is 2 because one plus one is two.

S
Desktop/ Pl & Unitled ° +

C Y @ localhost:890/notebooks/Desktop/Untitled.ipynb?kernel_name=python3
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: Jupyter Untitled Last Checkpoint 22 minutes ago (unsaved changes)

Edit View Insert Cell Kemel Widgets Help
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Open

Make a Copy.
Save as.
Rename...

Save and Checkpoint
Revert to Checkpoint »

Print Preview

Download as >

FIGURE 1-15:
Result of running

code in a Jupyter

Notebook cell.

Trusted Notebook

To close a notebook, you can used either of these methods:

3 Close the tab in the browser that's showing the cell.

¥ Or, choose File=>Close and Halt from the toolbar above the cells.

Figure 1-15 shows an example using Chrome as the browser. Your tabs may look
different if you’re using a different browser. You may be prompted to save your
work. For now, you don’t need to save because we’re just focused on the absolute
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basics . . . the thing you may be doing every time you want to run some Python
code.

Even if you don’t specifically save a notebook, you will see an icon for it in the
folder in which you created the notebook. Its name will be Untitled, and if you
have filename extensions visible, you’ll see a .ipynb filename extension. The pynb
part is short for Python notebook. The i in that extension, in case you’re wonder-
ing, comes from iPython, which is the name of the app from which Jupyter Note-
book was created, and is short for “interactive.”

You can delete a notebook file if you are just practicing and don’t want to keep it.
Just make sure you close the notebook in the web browser (or just close the whole
browser first) — otherwise, you may get an error message stating that you can’t
delete the file while it’s open.

So now you are ready to go. You have great set of tools set up for learning Python.
The simple skills you’ve learned in this chapter will serve you well through your
learning process, as well as you professional programming after you’ve mastered
the basics. Come on over to Chapter 2 in this minibook now and we’ll get a bit
deeper into Python and using the tools you now have available on your computer.
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IN THIS CHAPTER

» Using the Python interactive mode

» Creating a Python development
workspace

» Create a folder for your Python code

» Typing, editing, and debugging
Python code

» Writing code in a Jupyter notebook

Chapter 2

Interactive Mode,
Getting Help,
Writing Apps

ow that you have Anaconda and VS Code installed, you’re ready to start

digging deeper into writing Python code. In this chapter we take you

briefly through the interactive, help, and code editing features of VS Code
and Jupyter Notebook to build on what you’ve learned so far. Most of you are
probably anxious to get started on more advanced topics like data science, artifi-
cial intelligence, robotics, or whatever. But learning that will be easier if you have
a good understand of the many tools available to you, and the skills to use them.

Using Python Interactive Mode

Many teachers and authors will suggest you try things hands-on at the Python
prompt, and assume you already know how to get there. We’ve seen many frus-
trated beginners complain that trying activities recommended in some tutorial
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FIGURE 2-1:

Terminal pane
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in VS Code.

never work for them. The frustration often steps from the fact that they’re typing
and executing the code in the wrong place. With Anaconda, the Terminal in VS
Code is a great place to type Python code. So in this chapter we’ll start with that.

Opening Terminal

To use Python interactively with Anaconda, we suggest you follow these steps:

1. Open Anaconda Navigator, then open VS Code by clicking its Launch
button on the Anaconda home page.

2. If you don’t see the Terminal pane at the bottom of the VS Code window,
choose View > Terminal from the VS Code menu bar.

3. If the words Terminal isn’t highlighted at the top of the pane, click
Terminal (circled in Figure 2-1).

PROBLEMS  OUTPUT :EE;::;:,E 1: powershell ML |

Windows Powershell
Copyright (C) Microsoft Corporation. All rights reserved.

PS C:\WsershAlan»

The very first prompt you see is typically for your computer’s operating system,
and likely shows the user name of the account you’re in. For example, on a Mac it
may look like Alans-Air:~ alan$ but with the name of your computer in place of
Alans-Air. In Windows it would likely be C: \Users\Alan> with your user name in
place of Alan, and possibly a path that’s different from C: \Users.

Getting your Python version

At the operating system command prompt, you can type this and press Enter to
see what version of Python you’re using. Note that there is a space before the first
hyphen, and no other spaces.

python —-version
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COLORS AND ICONS IN VS CODE

By default, the VS Code terminal displays white text against a black background. We will
be reversing those colors in this book, just because we think the dark against light works
better for print like this. You're welcome to use any color scheme you like. If you just
want to switch to black on white, as shown in this book, use either of these methods:

On a Mac choose Code =>Preferences = Color Theme = Light (Visual Studio).
In Windows choose File => Preferences =>Color Theme = Light (Visual Studio).

If you want your icons in VS Code to match the ones we're using, you'll need to down-
load and install the Material Icon Theme. You may also want to download the Material
color theme and try it out. We won't be using it for the book because it doesn't play well
when printed on paper. But you may want to take it for a spin. Follow these steps:

1. Click Extensions in the left pane.

2. Type material, look for Material Icon Theme, and click its Install option.

3. Click Reload on any selected extension to install both extensions. If you
see a prompt at bottom right asking if you want to activate the icons,
click Activate.

4. Choose File (in Windows) or Code (on a Mac) then Preferences =>File Icon
Theme then click Material Icon Theme.

5. If you'd like to try out the color theme, open File (in Windows) or Code
(on a Mac) and then choose Preferences => Color Theme and click Material
Icon Theme.

If at any time you change your mind about the color theme, repeat step 5 above and
choose something other than Material Icon Theme.

You should see something like Python 3.x.x (where the x’s are numbers rep-
resenting the version of Python you’re using. If instead you see an error mes-
sage, you’re not quite where you need to be. You want to make sure you start VS
Code from within Anaconda, not just from Launchpad or your Start menu. Type
python --version in the VS Code Terminal pane, and press Enter again. If it still
doesn’t work, choose View= Command Palette from the VS Code menu bar, type
python, choose Python: Select Interpreter, and then choose the Python interpreter

you downloaded with Anaconda.
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Going into the Python Interpreter

When you’re able to enter python --version and not get an error, you know
you’re ready to work with Python in VS Code. From there you can get into the
Python interpreter by entering the command

python

the command and then press Enter. Nothing happens until you press Enter. So if
you just type the command and wait for something to happen, you will be waiting
rememeer  for a long, long time.

@ When we, or anyone else, says “enter the command,” that means you have to type

You should see some information about the Python version you’re using, and
the »>> prompt, which represents the Python interpreter.

Entering commands

Entering commands in the Python interpreter is the same as typing the anywhere
else. You must type the command correctly, and then press Enter. If you spell
something wrong in the command, you will likely see an error message, which is
just the interpreter telling you it doesn’t understand what you mean. But don’t
worry, you can’t break anything. For example if you enter the command

howdy

A NOTE ABOUT PyLint

PyLint is a feature of Anacaona that helps you find and avoid errors in your code.
It's usually turned on by default. Though in the past we've gotten different results
with different VS Code versions. It's possible that the first time you try to use Python
you'll see some messages in the lower-right corner of VS Code. Don't be alarmed if
you don't see them. If you do see any, however, here is how you can respond:

If you see a message about Python Language Server, click Try It Now and then click
Reload.

If you see a message that Linter PyLint Is Not Installed, click Install.
If you see Select Python Environment near the lower-left corner of VS Code’s window, click

that and choose the Anaconda option from the menu that drops down near the top cen-
ter. If you see multiple Anaconda options, choose the one with the largest version number.
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FIGURE 2-2:
Python doesn't
know what
howdy means.

After you press Enter, you see some techie gibberish on the screen that is trying to
tell you that it doesn’t know what “howdy” means, so it can’t do that. But again,
nothing has broken. You’re just back to another >>> prompt where you can try
again, as shown in Figure 2-2.

PROBLEMS ~ OUTPUT  DEBUG CONSOLE  TERMIMAL 1: python 4+ T B ~ O

{c) 2018 Microsoft Corporation. All rights reserved.

(base) C:\Users\Alan»python --version

Python 3.7.8

(base) C:\Users\Alan>python

Python 2.7.0 (default, Jun 28 2018, 03:084:48) [MSC v.1912 &4 bit (AMDB4)] :: Anaconda, Inc. on win32
Type "help", "copyright", "credits" or "license" for more information.

>3 howdy

Traceback (most recent call last):
File "<stdin»", line 1, in <module>
NameError: name "howdy' is not defined

Using Python’s built-in help

On of the prompts on your screen mentioned that you can type help as a comment
in the Python interpreter. Note that you don’t type the quotation marks, just the
word help (and then press Enter, as always). This time you see

Type help() for interactive help, or help(object) for help about object.

Note that this time they’re telling you to type help followed by an empty pair of
parentheses, or help with a specific word in parentheses (object is the example
given). Even though they use the word “type” at the start of the sentence, they
mean to enter the command. . .type it and press Enter. Go ahead and enter

help()

Note that there are no spaces in the line. After you press Enter the screen provides
some information about using Python’s interactive help, as shown in Figure 2-3.

Seeing help> at the bottom of the window tells you that you’re no longer in the
operating system shell or the Python interpreter (which always shows >>>) but
are now in a new area that provides help. Any commands you type here should be
ones that the help recognizes. As a beginner you’re not likely to know those. But
for future reference know you can use this help prompt for reminders about dif-
ferent parts of Python.
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FIGURE 2-3:
Python's
interactive
help utility.

FIGURE 2-4:
Keyword help.

TERMINAL 1: python v+ M@ A~ O x
>»> help()

Welcome to Python 3.7's help utility!

If this is your first time using Python, you should definitely check out
the tutorial on the Internet at https://docs.python.org/3.7/tutorial/.

Enter the name of any medule, keyword, or topic to get help on writing
Python programs and using Python modules. To quit this help utility and
return to the interpreter, just type "quit".

To get a list of available modules, keywords, symbols, or topics, type
"modules”, "keywords", "symbols", or "topics". Each module also comes
with a one-line summary of what it does; to list the modules whose name
or summary contain a given string such as "spam”, type "modules spam”.

help> []

For example, Python uses certain keywords, which have special meaning in the
language. You get a list of those, just type

keywords

at the help> prompt and press Enter, and you’ll see a list of keywords, as in
Figure 2-4.

OUTPUT  TERMINAL === 1: pythen v+ M@ A O X
help> keywords
Here is a list of the Python keywords. Enter any keyword to get more help.
False class from or
None continue global pass
True def if raise
and del import return
as elif in try
assert else is while
A5yNC except lambda with
await finally nonlocal yield
break for not
help> I

@ a

Above the list of keywords it tells you that you can type any keyword at the help>
prompt for more information about that keyword. For example, entering the key-
word class provides information about Python classes, as shown in Figure 2-5.
These are not the kind of classes you attend at school; rather, they’re the kind you
create in Python (after you’ve learned the basics and are ready to move onto more
advanced topics).

Needless to say, all the technical jargon in the help text is going to leave the aver-
age beginner totally flummoxed. But the point here is that, for future reference,
as you learn about things in Python, you can use the Python interactive help for
reminders on those concepts as needed.
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FIGURE 2-6:
Back to the

operating system

prompt.

PROBLEMS ~ QUTPUT  TERMINAL === 1: powershell o4+ @D oA @ x
See also: **PEP 3115** - Metaclasses in Python 3 **PEP 3120%*
Class Decorators
Related help topics: CLASSES, SPECIALMETHODS
help> g

You are now leaving help and returning to the Python interpreter.

If you want to ask for help on a particular object directly from the
interpreter, you can type "help(object)”. Executing "help{'string’)"
has the same effect as typing 2 particular string at the help» prompt.

() or Ctrl-Z plus Return to exit
>3 exit()
Ps C:\Usersialan> ]

Regardless of what you use to search, remember to start your search with the
word python or python 3. A lot of programming languages out there share similar
concepts and keywords, so if you don’t specify the Python language in your search
request, there’s no telling what kinds of results you may get.

Lots of free cheat sheets

Another good resource for learners are the countless cheat sheets available online
for free. Whenever you start to feel overwhelmed by all the possibilities of a language
like Python, a cheat sheet summarizing things down to a single page or so can really
help bring things down to a more manageable (and less intimidating) size.

Of course, you’re not really “cheating” with a cheat sheet, unless you us it while
taking a test that you’re supposed to answer from memory. But writing code in
real life is much different from answering multiple-choice questions. So what we
often call a cheat sheet in the tech world is really just another tool to help you learn.
There are many of them out there, and exactly what appeals to you depends on
your own learning style. To see what’s available, just head out to Google or Bing
or any search engine you like and search for free python 3 cheat sheet. Most are in a
format you can download, print, and keep handy as you learn the seemingly infi-
nite possibilities of writing code in Python.

Creating a Python Development
Workspace

34

Although interactive modes and online help and the rest are certainly decent sup-
port tools, most people want to use Python to create apps. Personally, we’ve found
this easiest to do if you set up a VS Code development environment specifically for
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learning and doing Python. You can set up other development environments for
other types of coding, such as HTML, CSS, and JavaScript for the Web, fine-tuning
each as you go along to best support whatever language you’re working in.

We often switch between Mac and Windows computers, and so we actually have
one dev environment for each. Alan keep his in a OneDrive folder so he can get to
them from anywhere. Although this is certainly not a requirement, it sure comes
in handy. But if you’ll be working strictly from one computer, you can put your
environment on your computer’s hard drive rather than out on a cloud drive.

In VS Code, they use the term workspace to define what we call a development
environment. It’s basically the specific Python interpreter you're using plus any
additional extensions you gather along to the way to make learning and doing
easier.

To make it easy to get to these workspaces from any Internet-connected computer
in the world, Alan has a folder on a cloud drive (OneDrive) named VS Code Work-
spaces. However, you can store your workspaces anyplace you like — even on your
own computer, if you don’t have or don’t want to use a cloud drive. But if you do
want to create a folder for storing workspaces, do so now, before proceeding with
the following steps. Then

1. Ifvs codeisn't already open, open launch it from Anaconda.
Choose File =>Save Workspace As.

2.
3. Navigate to the folder in which you want to save the workspace settings.
4.

Type a name for the workspace. Alan uses Python 3 followed by Mac or
Windows depending on which type of machine he's on, as shown in
Figure 2-7.

On a Mac, choose Code = Preferences = Settings.
In Windows, choose File &> Preferences = Settings.

5. you see a page like the one in Figure 2-7, click the three dots near the
top-right corner and choose Open Settings.json, as shown in Figure 2-8.

6. Inthe next window, select the entire line of code that starts with python.
pythonpath (this tells VS Code where to find the Python interpreter on
your computer). You can also select any other command lines that you'd
like to make part of the workspace, but don’t select the curly braces.

7. click Workspace Settings above the code you just selected.
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&« v » OneDrive » V5 Code Workspaces v O Search VS Code Workspaces

File name: | Python 3 (Windows)

Save as type: | Code Workspace (*.code-workspace)

v Browse Folders

Save Cancel

Save As: |Python 3 (Mac).code-workspace | v
FIGURE 2-7: Tags:
Saving current
settings as Where: = [B OneDrive
workspace
Cancel Save
settings.
Settings %
Search settings 597 Settings Found
User Settings
- Showmocfw‘fied_seuings
i ::,(T':;:UI: Used Commonly Used Open settings.json
¥ Workbench Files: Auto Save
» Window Controls auto save of dirty files. Read more about autosave here.
» Features afterDelay :
» Application
 Extensions Files: Auto Save Delay
Controls the delay in ms after which a dirty file is saved automatically. Only applies when Files: Auto Save is set to
afterdelay.
FIGURE 2-8: 1000
VS Code Settings.

8. Cclick between the setting's curly braces and paste in the lines of code
there, as shown in Figure 2-9. Keep in mind that your python path may
not look like the one in the image.

USER SETTINGS WORKSPACE SETTINGS
L]
Place your settings here to overwrite the User Settings.
1 {
2 :
FIGURE 2-9: 3 "settings": {
Python path 4 "python.pythonPath™: "C:\\ProgramData\‘Anaconda3",
moved to 5 "workbench.colorTheme”: "Visual Studio Light"
workspace E }
settings. L
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9. Choose File > Save from the VS Code menu.

10. close the Settings and User Settings tabs by clicking the X on the right
side of each tab.

11. close Vs code.
12. close Anaconda.
You'll see how to take advantage of the new workspace settings in a moment.

But first, you’d be wise to create a directory (folder) to store all the code you’ll be
writing in this book so it’s easy to find when you want to review.

Creating a Folder for your Python Code

Next, we create a folder in which to store all the Python code that you write in
this book, so it’s all together in one place and easy to find when you need it. You
can put this folder anywhere you like. Alan again will use a cloud drive (OneDrive)
so he can get to it from any computer. But you can put yours wherever you like.
He’ll name his folder AIO Python (for All-In-One Python), but you can name yours
whatever you like.

The steps are the same as for any other folder, there’s nothing special about the
folder. In Windows you can navigate to the folder which will contain the new
folder (Alan would use OneDrive, but you can use your Desktop, Documents, or
any other folder). On a Mac, right-click some empty place in the folder and choose
New Folder. In Windows, right-click an empty spot in the folder and choose
New<= Folder. Type the folder name (AIO Python, in our example) and press Enter.

Last but not least, you want to associate the code folder you just created with the
VS Code workspace you just created, so that any time you work in the AIO Python
folder you’re using the correct Python interpreter and other Python-related set-
tings you choose over time with the files in the code folder. Here’s how:

. Open Anaconda and launch VS Code from there.

From the VS Code menu choose File=> Open Workspace.

Navigate to the folder where you saved your workspace and open the
workspace from there.

Choose File=>Add Folder to Workspace.

e WN=

. Navigate to the folder in which you created the AlO Python folder, click
that folder's icon, and choose Add.
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FIGURE 2-10:
Python 3

workspace and
AlO Python folder
open in VS Code.

38

TIP

The Explorer bar in VS Code shows that you have the workspace open, and under
that you can see you also have that folder open, as shown in Figure 2-10. If you see
something entirely different in the left pane, click the Explorer icon at the top-left
(near the arrow in the Figure) to make sure you’re viewing that pane.

Click for Explorer pane Open workspace

’ﬂ] Eile Edit Selection View Go Debug | Terminal Help

4 OPEN EDITORS
4 PYTHON 3 (WINDOWS) (WORKSPACE)
< AIO Python Open folder
4 wscode

settingsjson Folder settings

I
Explorer pane

The Open Editors bar lists files that are currently open (over to the right). For
example, if you see Welcome there, that means you’re viewing the Welcome page.
To close that page, click the X next to its name in the Explorer pane or tab. Any
time you want to reopen that Welcome page, choose Help=> Welcome from the VS
Code menu bar.

The .vscode icon is just a subfolder that stores your settings for this workspace,
and settings.json is the file in that folder that contains those settings. The triangle
next to each name allows you to expand or collapse that list. So if something is
hidden, click the triangle next to an item to expand that item and see what it
contains.

If you see a symbol other than a triangle, or no symbol at all, next to folder names,
you maybe be using an icon theme that’s different from the default. No worries,
just click to the left of any folder to expand/collapse it even if there’s no symbol
there at all.

The beauty of this approach now is that any time you want to work with Python in
VS Code, all you have to do is follow these steps:
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If you've closed VS Code, launch it from Anaconda Navigator.

N

Choose File > Open Workspace from the VS Code menu.
3. Open your workspace.

The workspace and any folders you've associated with that workspace open
up, and you're ready to go.

Typing, Editing, and Debugging
Python Code

Most likely, the vast majority of code you write you’ll write in and editor. This will
be a plain text file with a .py filename extension. For this book, we suggest you
keep any files you create in that AIO Python folder which you should be able to see
any time you have VS Code and your Python 3 workspace open. So to create a .py
file at any time, follow these steps:

1. you haven’t already done so, open VS Code on your Python 3
workspace.

2. Ifthe Explorer pane isn’t open, click the Explorer icon near the top-left of
VS Code.

3. Tocreate a new filein your AlO Python folder, right-click AlO Python and
choose New File (Figure 2-11).

4, Type the filename with the .py extension (hello.py for this first one) and
press ENTER.

4] File Edit Selection View Go Debug Terminal Help

R
4 OPEN EDITORS
4 PYTHON 3 (WINDOWS) (WORKSPACE) N E o
4 AIO Python {b
4 vscode Mew File

settings.js

FIGURE 2-11: Reveal in Explorer Shift+Al+R
Right-click a Open in Termina
folder name and - .
Add Folder to Workspace...

choose New File.
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The new file opens and you can see its name on top of the tab to the right.
That larger area is where you'll type your Python code. You'll also see hello.py
under Open Editors. That's just a convenience so that when you have many
open files you can pick one to bring to the forefront just by clicking its name
there. The filename also appears under the AUO Python folder name in the
Explorer pane, because that's where it's stored, as shown in Figure 2-12.

ﬂ] File Edit Selection View Go Debug Terminal Help hello.py -

4 OPEN EDITORS 1]

4 PYTHON 3 (WINDOWS) (WORKSPACE)
4 AlO Python
4 nscode

settingsjson

FIGURE 2-12:
New hello.py file
open in VS Code

for editing.

Writing Python code

Now that you have a py file open, you can use it to write some Python code.
As it typical when learning a new programming language you’ll start by typing a
simple Hello World program. Here are the steps:

1. click next to the 1 in the editing area.

2. Type (exactly) print(“Hello World”), and as you're typing you may notice
text appearing on the screen. That is intellisense text, which detects what
you're typing and shows you some information about that keyword. You
don’t have to do anything with that though, just keep typing.

3. Press Enter after you've typed the line.
The new line of code shows, but doesn’t execute. That’s because you typically

don’t type and run one line of code at a time. You may also notice a couple of other
changes, as shown in Figure 2-13:

¥ The Explorer icon shows a circled 1, indicating that you current have one
unsaved change.

3 The hello.py name in the tab and Open Editors areas show a dot, indicating
that you have unsaved changes in the file.
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FIGURE 2-13:
hello.py contains
some python
code and has
unsaved changes.

Unsaved changes indicators

jel Go Debug lerm\'na\ﬁy\ * hellopy]

@ hellopy ~®

4] File Edit Selecii

1 print("Hello World")
2

® @ hello.py
4 PYTHON 3 (WINDOWS) (WORKSPACE)

settingsson
@ hello.py

Python code

Saving your code

Code you type in VS Code is saved automatically. There are a couple of ways to deal
with that. One is to try to remember to save any time you make a change that’s
worth saving. The easiest way to do that is to choose File=>Save from VS Code’s
menu bar, or press Ctrl + S in Windows or Command+S on a Mac.

Personally, we prefer to use AutoSave, which automatically saves changes you
make, so that you don’t have to remember. To enable Auto Save, just choose
File=> Auto Save from VS Code’s menu bar. When you see a checkmark next to
Auto Save on the File menu, that means Auto Save is turned on, so you don’t have
to remember to save every change. If you decide you no longer want to use Auto
Save at any time in the future, just choose File> Auto Save again from the menu
bar to remove the checkmark and turn Auto Save off.

Running Python in VS Code

To test your Python code in VS Code, you need to run it. The easiest way to do that
in VS Code is probably to right-click the file’s name (hello.py in this example) and
choose Run Python File in Terminal as shown in Figure 2-14.

The Terminal pane opens along the bottom of the VS Code window. You’ll see a
command prompt followed by a comment to run the code in the Python inter-
preter (python.exe). And below that, you’ll see the output of the program: the
words Hello World, in this example, and then another prompt, as in Figure 2-15.
This is not the most exciting app in the world, but at least now you know how to
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FIGURE 2-14:
Run hello.py.

FIGURE 2-15:
Output from
hello.py.

o
T
TECHNICAL
STUFF

write, save, and execute Python programs in VS Code, and that’s a skill you’ll be
using often as you continue through this book and through your Python program-
ming career.

4] File Edit Selection View Go Debug Terminal Help hello.py - Python 3 (Windows) (Workspace) - Visual Studio Code
EXPLORER % hellopy X
4 OPEN EDITORS 1 print("Helle Werld")
x & hello.py 2
4 PYTHON 3 (WINDOWS) (WORKSPACE)
4 AIO Python
4 vscode

settingsjson

L] %eHc.pv{kj

Open to the S

Reveal

Open in Termina

Select for Compare

Rename

Delete Delete

Debug All Unit Tests

Run All Unit Tests

Run Python File in Terminal

PROBLEMS ~ OUTPUT  DEBUG CONSOLE  TERMINAL 1: Python 4+ Mm@ O~ O %
Windows PowerShell

Copyright (C) Microsoft Corporation. All rights reserved.

PS C:\Wsers\alan\OneDrive\AIO Python> & "c:/Users/Alan/OneDrive/AI0 Python/hello.py”
Hello World
PS C:\Wsers\Alan\OneDrive\AI0 Python>

If you are using PowerShell in the Terminal window you may see a message about
switching to the Command Prompt. Unless you happen to be a PowerShell expert
and really need it (for whatever reason), you might as well click Use Command
Prompt if you see that option so that prompt won’t keep pestering you in the
future.

Simple debugging

When you’re first learning to write code, you’re bound to make a lot of mistakes.
The good news is that they’re no big deal. You won’t break or destroy anything.
The code just won’t work as expected.
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Before you even attempt to run some code, you may see several indicators on the
screen indicating that there is an error in your code:

¥ The name of the folder and file that contain the error will be red in the
Explorer pane.

¥ The number of errors in the file will show in red next to the filename in the
Explorer bar.

¥ The total number of errors will show next to the circled X at the bottom left
corner of the CS Code window.

3 The bad code will likely have a wave red underline beneath it.

Figure 2-16 shows an example where we typed PRINT in all uppercase, which is
not allowed in Python. Python is case sensitive, so when we show a command to
type in lowercase, that means you have to type it in lowercase, too.

”!] Eile Edit Selection View Go Debug Terminal Help hello.py - Pythol
G‘I EXPLORER @ hellopy %
4 OPEN EDITORS 1 PRINT("Hellec World")

p X @ hello.py 1 2

4 PYTHON 3 (WINDOWS) (WORKSPACE)

o0 4 AIO Python
4 wvscode
settingsjson
eee @ hello.py
FIGURE 2-16:
PRINT is typed o)
b OUTLINE

incorrectly in
hello.py.

Python 3.7.0 64-bit (base: conda) @1 A0

To run the file in Terminal, you’ll have to fix the error. Touching the mouse
pointer to the word with the red wavy line below will give you a brief (though
highly technical) description of the problem. In the example shown in the image,
we just typed PRINT (uppercase) rather than print (lowercase). So, to fix the error
we would just replace PRINT with print and then save the change (unless you’ve
turned on Auto Save). Then you can right-click and choose Run Python File in
Terminal to run the corrected code.

The VS Code Python debugger

VS Code also has a built-in debugger that can help when working with more com-
plex programs and also provides another means of running Python programs in
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VS Code. We won’t be doing anything super complex right now. But there certainly
is no harm in getting the debugger set up and ready as part of your Python devel-
opment workspace. Follow these steps to do so now:

1.
2.

3.

4.

Click the Debug icon to the left of the Explorer pane.

Next to No Configurations near the top of the pane click the Gear icon
(which is probably showing a red dot right now, because you haven't
specified a debugger yet). A new file named launch.json opens to the
right.

Click open the drop-down menu at the top of the pane and choose
Python: Current File (Integrated Terminal) (AlO Python), as shown in
Figure 2-17.

Close launch.json by clicking the X on its tab.

From now on, as an alternative to using the right-click method to run Python
code, you can use the Debug pane. But first, you have to know which file will run.
For now that’s easy because hello.py is the only one we have. In the future, when
you may have several open, you can tell which one is open because it appears in
the editing area to the right of the explore pane. To run it, from the Debug pane,
click the Start Debugging arrow near the top of the Debug pane, which shows as
a green triangle.

Start Debugging

4] File Edit IS:\E[ticr' View Go Debug Terminal Help aunchjson - Python 3 (Windows) (Workspace) - Visual Studio
DEBUG P | Python: Current File (Integrated Terminal) (AIO Python) ¥ | ¥ [ L] launch,json ¥
) T I Python: C ile ( rated Terminal) (AlO Python) 1 [

2 // Use IntelliSen
3 // Hover to view
4 // For more infor
5 "version": "@.2.8
6 "configurations”:

7 {
8 "name": "
9 "type": "
18 "request”
11 "program"
12 "console”

13 1

14 {

FIGURE 2-17:
VS Code |

Debug pane.  Open Debug pane

When you click Start Debugging, the Python code will run as it did when you chose
Run Python File in Terminal. However, it will take a little longer, and there will be
more text output on the screen in Terminal. However, so long as there aren’t any
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actual errors, you should see the output under all of that (Hello World) followed
by the command prompt for your operating system.

If that seems like a lot to remember, for now all you have to do is remember that
whenever you want to run the some Python code in VS Code, you can do either of
the following, whichever is most convenient for you at the moment:

¥ Right-click the .py file's name and choose Run File in Terminal.

¥ Click the .py file's name in the Explorer bar to select that file, click Debug, and
then click Start Debugging at the top of the Debug pane.

If you can remember those two things, you’re well on your way to learning Python,
and you have a good environment in which to work.

Writing Code in a Jupyter Notebook

In Chapter 1 you learned about Jupyter notebooks as another way to write and
run Python code. In this chapter, we’d like to build on what you learned there by
showing you how to create, save, and open Jupyter notebooks. You can, of course,
save your Jupyter notebooks wherever you want using any filenames you want.
For our working example here we’ll create subfolder named Jupyter Notebooks
inside your AIO Python folder just to keep everything together.

Creating a folder for Jupyter Notebook

A Jupyter Notebooks folder is no different from any other, so you can create it
using whatever method you normally use in your operating system. We’ll put ours
in the AIO Python folder we created, again just to keep all the files for this book in
one place. The steps to do this are as follows:

1 . Open your AlO Python folder in Finder (Mac) or Explorer (Windows).

2. Right-click an empty spot in that folder and choose New > Folder (in
Windows) or New Folder on a Mac.

3. Type Jupyter Notebooks as the folder name and press Enter.

Now that you have a folder in which to save Jupyter notebooks, you can create a
notebook, as discussed next.
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FIGURE 2-18:
01 Notebook

created in Jupyter

46

Notebook.

Creating and saving a Jupyter notebook

To create a Jupyter notebook and save it in a folder, follow these steps:
1. Open Anaconda (if it isn't already open) and launch Jupyter Notebooks
from there.

2. Onthefirst page, navigate to the Jupyter Notebooks folder you created
in the previous section. You should see something like The notebook list is
empty because the folder is empty.

3. Cclick New and choose Python 3.
4. Nearthe top of the new notebook that opened click Untitled, type in the

new name 01 Notebook, and click Rename.

That’s it, the notebook is created and saved in your AIO Python folder as shown
in Figure 2-18.

- Jupyter Quit Logout

Files Running Clusters

[Select items to perform actions on them

up oa
MNotebook:

0  ~ | B/ OneDrive /(AIO Python Name ¥ e
Python 3

]

O hel o.py Text File 2B
Folder

Terminal

Typing and running code in a notebook

When your notebook is open, you can type Python code into any Code cell and text
into any Markdown cell. When you see the word Code in the drop-down menu in
the toolbar below the menu bar, the active cell is for typing code. To take it for a
spin, follow these steps:

1. clickin the Code cell (to the right of In [ ]: and type print(“Hello World") and
don't forget to use lowercase letters for the word print.

2. Torunthe code, hold down the Alt key (in Windows) or the Option key
(on a Mac) and press Enter, or click the Play triangle to the left of the
word In.

The output from the code appears below the cell, and another cell opens
below.
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B + 3 &G B 4+ % MRin B C » code v | =

In [3]:  print(“"Hello World")

Hello World

Markdown Text in Jupyter Notebooks

A Markdown cellin a Jupyter Notepook cell can contain any text that's formatted with Markdown.
Idardown is a relative simple language for marking up test with headings, lists, pictures, videos, and
more. Below is a video from YouTube that plays in this Notebook.

~ jupyter
Noteboo

FIGURE 2-20:
A Markdown

cell with some s
and text in it.

Saving and opening notebooks

To save a Jupyter notebook, click the Save button on the toolbar, or choose
File=> Save and Checkpoint from the menu.

To close a notebook, choose File=> Save and Halt from the menu.

Any time that you want to reopen a notebook in the future, open Anaconda and
launch Jupyter Notebook from there. Then, navigate to the file you saved and click
its filename. The filename will probably show a .ipynb filename extension, as
that’s standard for Jupyter notebooks.

It’s worth noting that when you open the AIO Python folder in VS Code, you’ll
see the new Jupyter Notebooks folder in the Explorer pane. Keep in mind that we
put that folder there just to keep files from this book organized. There wouldn’t
really be any reason to open that folder in VS Code. The folder is named Jupyter
Notebooks because it’s just for files you create and manage in the Jupyter Note-
book app.

Okay, so we’ve dug a little deeper in VS Code and Jupyter Notebook here, mostly
so that you can save and open Python files and Jupyter Notebooks whenever you
want in future chapters. All of these skills will prove useful when you start getting
deeper into writing Python code. See you there!
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» The Zen of Python

» Understanding object-oriented
programming

» Indentations count, big time

» Using Python modules

Chapter 3

Python Elements
and Syntax

any programming languages focus on things that the computer does and
how it does them rather than on the way humans think and work. This
one simple fact makes most programming languages difficult for most
people to learn. Python is different in that’s is based on the philosophy that a
programming language should be geared more toward how humans think, work,
and communicate than what happens inside the computer. The Zen of Python is
the perfect example of that human orientation, so we start this chapter with that.

The Zen of Python

The Zen of Python is a list of guiding principles for the design of the Python
language. (See Figure 3-1.) These principles are actually hidden in an Easter egg
(a slang term for something in a programming language or app that’s not easy to
find and that serves as a bit of an inside joke to people who have learned enough
Python to be able to find it). To get to the Easter egg, follow these steps:

1. Launch Vs Code from Anaconda Navigator and open your Python 3
workspace.

2. Ifthe Terminal pane isn’t open, choose View =>Terminal from the VS Code
menu bar.
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style consistency will become more apparent, and you’ll find it easier and easier
to read and understand other peoples’ code, which is an excellent way to learn
coding yourself.

We’ll fill you in on Python coding style as we go along in this book. Trying to read
about it before actually working on it is sure to bore you to tears. So for now, any
time you hear mention of PEP, or especially PEP 8, remember that it’s a reference
to the Python Coding Style Guidelines from the Python.org website, and you can
find it any time you like just by googling pep 8.

Truthfully, this PEP 8 business can be a kind of double-edged sword for learners.
On one hand, you don’t want to learn a bunch of bad habits only to discover you
have to unlearn them later. On the other hand, the formatting demands of PEP
8 are so strict many learners get frustrated just trying to get the stuff to work
without having to worry about blank spaces, upper-/lowercase letters, and other
details.

To deal with all of this, we will be following and explaining PEP 8 conventions as
we go along. You can take it a step further, if you like, by configuring PyLint to
help you along. PyLint is a tool that comes with Anaconda that makes suggestions
about your code as you’re typing. Follow these steps to turn on Pylint and PEP 8
now if you’d like to take it for a spin:

. Onthe Mac menu, click Code; in Windows, click File on the menu.

Choose Preferences > Settings.

Click Workspace Settings.

Click the three dots near the top-right of the settings and choose Open
Settings.json.

Click Workspace Settings.

In the Search Settings box, type pylint.

Touch the mouse pointer to python.linting.enabled, and if that option
isn't enabled, click it and select True to enable linting.

0 NoOWU AWN=

Scroll down and touch the mouse pointer to python.linting.pep8Enabled,
click the little pencil icon that shows, and click True.

You'll see a couple of lines added to your Workspace Settings, each starting
with python.linting, as shown in Figure 3-2.
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FIGURE 3-2:
Workspace
settings with
Pylint and

PEP 8 enabled.

FIGURE 3-3:

A different view
of Workspace
Settings.

GS WORKSPACE SETTINGS AIO PYTHON Foider Settings
Place your settings here to overwrite the User Settings.
1 {
2
3
4
5
6 s
7 "settings": {
8 "python.pythonPath”: "C:\\ProgramData\‘Anaconda3",
9 "terminal.integrated.shell.windows™: "C:\\WINDOWS\\System32\\cmd.exe",
1@ "workbench.colorTheme": "visual Studio Light",
11 "python.linting.enabled™: true,
12 "python.linting.pep8Enabled™: true,
13
14
15 3
16}

When you’re done, choose File=> Save All. Then you can close the settings pages by
clicking the X in their tabs. If at any time in the future you feel that the linting is
just too much and is actually making it harder for you to learn, you can turn those
features off by following these steps:

1 . Choose Code > Preferences > Settings (on a Mac) or File>Preferences >
Settings (in Windows).

2. click Workspace Settings, and then click the three dots and choose Show
Modified Settings.

You will see Workspace settings in the non-code format shown in Figure 3-3.

@modified

User Settings Workspace Settings  AIO Python Folder Set

4 Workbench

Workbench: Color Theme
Specifies the color theme used in the workbench,

Visual Studio Light v

ython Configurat... (2 Terminal > Integrated > Shell: Windows
The path of the shell that the terminal uses on Windows. Read more about configuring the shell.

CAWINDOWS\System32\cmd.exe

Python - Linting: Enabled
| Whether to lint Python files.

Python - Linting: Pep8Enabled
| Whether to lint Python files using pep8

Python: Python Path
Path to Python, you can use a custom version of Python by modifying this setting to include the full path.

C:\ProgramData\Anaconda3
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3. If you want to disable just PEP 8 (which is the one that drives most
beginners a little crazy), click the checkmark for Python = Linting:
Pep8Enabled.

Try things with PEP 8 disabled. If the linting still feels like it's too much, you can
repeat the steps and clear the checkmark next to Python = Linting:Enabled.

Object-Oriented Programming

At the risk of getting too technical/computer science-y, we should mention that
there are different kinds of languages and different approaches to designing
languages. Perhaps the most successful and widely used model is what’s called
object-oriented programming, or OOP for short. It’s a design philosophy that tries
to mimic the real world in the sense that it consists of objects, with properties,
and methods (actions) that those objects perform.

Take a car, for example. Any one car is an object. Not all cars are exactly the same.
Different cars have different properties, such as make, model, year, color, size,
and so forth that make them different from one another. And yet, they all serve
the same basic purpose.. . . to get us from point A to point B without having to walk
or use some other mode of transportation.

All cars have certain methods (things they can do) in common. We can drive them,
steer them, speed them up, slow them down, control the inside temperature, and
more using controls within the car that we can manipulate with our hands.

An object in an object-oriented programming language isn’t a physical thing, like
a car, because it exists only inside a computer. However, you can have a class
(which you can think as an object creator, such as a car factory) that can pro-
duce many different kinds of objects (cars) for varying purposes (sporty, off-road,
sedan). All these objects can be controlled through the controls that all have in
common, much as all cars are controlled by the steering wheel, brakes, accelera-
tor, and gearshift.

Python is very much an object-oriented language. This may not be readily appar-
ent when you first start learning because the core language consists of “controls”
(in the form of words) that allow you to control all different kinds of objects. You
need to learn the core language first so that when you’re ready to start using other
peoples’ objects, you know how to do so. This is sort of like, once you know how
to drive one car, you pretty much know how to drive them all. You don’t have to
worry about renting a car only to discover that the accelerator is on the roof, the
steering wheel on the floor, and you have to use voice commands rather than a
brake to slow it down. The basic skill of “driving” applies to all cars.
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Indentations Count, Big Time

In terms of the basic style of writing code, the one thing that really makes Python
different from other languages is that it uses indentations rather than parenthe-
ses and curly braces and such, to indicate “blocks” or “chunks” of code. In this
book, we don’t assume you’re familiar with other languages, so don’t worry if
that means nothing to you. But if you do happen to have some familiarity with
a language like JavaScript, you know that there’s quite a bit of wrangling with
parentheses and such to control “what’s inside of what.” For example, here’s
some JavaScript code. If you’re familiar with the Magic 8 Ball toy, you may have a
sense of what this program is doing. But that’s not what’s important. Just notice
that there are a lot of parentheses, curly braces, and semicolons in there:

document . addEventListener ("DOMContentLoaded", function () {var question =
prompt("Ask magic 8 ball a question");var answer = Math.floor(Math.random()
* 8) +1; if (answer == 1) {alert("It is certain");} else if (answer == 2)
{alert("Outlook good");} else if (answer == 3) {alert("You may rely on
it");} else if (answer == 4) {alert("Ask again later");} else if (answer ==
5) {alert("Concentrate and ask again");} else if (answer == 6) {alert
("Reply hazy, try again");} else if (answer == 7) {alert("My reply is
no");} else if (answer == 8) {alert("My sources say no")} else {alert
("That's not a question");}alert("The end");})

That code is a mess and not fun to read. We can make reading it a little easier by
breaking it into multiple lines and indenting some of those lines. Doing so isn’t
required in JavaScript, but it can be done to make the code a little easier for a
human to read, as shown below:

document . addEventListener ("DOMContentLoaded", function () {
var question = prompt("Ask magic 8 ball a question");
var answer = Math.floor(Math.random() % 8) + 1;
if (answer == 1) {
alert("It is certain");
} else if (answer == 2) {
alert("Outlook good");
} else if (answer == 3) {
alert("You may rely on it");
} else if (answer == 4) {
alert("Ask again later");

—

else if (answer == 5) {
alert("Concentrate and ask again");
} else if (answer == 6) {
alert("Reply hazy, try again")
} else if (answer == T7) {
alert("My reply is no");
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} else if (answer == 8) {
alert("My sources say no")
} else {
alert("That's not a question");}
alert("The end")
b

In JavaScript, all the parentheses and curly braces are required because they iden-
tify where chunks of code begin and end. The indentations for readability are
optional.

Things are quite the opposite in Python because Python doesn’t use curly braces
or any other special characters to mark the beginnings and ends of blocks of
code. The indentations themselves mark those. So those indentations aren’t at all
optional — they are in fact required, and they have a considerable impact on how
the code runs. But the upside is, when you read the code, (as a human, not as a
computer), it’s relatively easy to see what’s going on, and you’re not distracted
by a ton of extra quotation marks. Here is that JavaScript code written in Python:

import random
question = input("Ask magic 8 ball a question")
answer = random.randint(1,8)
if answer ==

print("It is certain")
elif answer ==

print("Outlook good")
elif answer == 3:

print("You may rely on it")
elif answer == 4:

print("Ask again later")
elif answer == 5:

print("Concentrate and ask again")
elif answer ==

print("Reply hazy, try again")
elif answer == T:

print ("My reply is no")
elif answer == 8:

print ("My sources say nho")
else:

print("That's not a question")
print ("The end")

You may notice at the top of the Python code there is a line that starts with the
word import. Those are very common in Python, and you’ll see why in the next
section.
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Using Python Modules

56

One of the secrets to Python’s success is that it’s comprised of a relatively simple,
clean, core language. That’s the part you really need to learn first. In addition to
that core language, there are many, many modules out there that you can grab for
free and access from your own code. These modules are also written in the core
language, but you don’t really need to see that or even know it, because you can
access all the power of the modules from the basic core language.

Most modules are for some kind of specific application like science or numbers or
artificial intelligence or working with dates and time or . . . whatever. The beauty
of it is that somebody else (probably a lot of people) spent a lot of time creat-
ing, testing, and fine-tuning that module so you don’t have to. You just have to
import whichever modules you want into your own .py file, and use the modules’
capabilities as instructed in the documentation that’s available for each module.

The preceding sample Magic 8 Ball program starts with this line:

import random

As it turns out, the core Python language has nothing built into it to generate a
random number. Although we could probably figure out some way to make one,
there’s no need to because somebody else has already figured out how to do this
and made the code freely available. Starting our program with import random tells
the program we want to use the capabilities of that module to generate a random
number. Then, later in the program, we generate a random number between 1 and
8 with this specific line of code:

answer = random.randint(1,8)

Using the existing module saves me from having to reinvent the wheel trying
to figure out how to make a random number from the core language. And there
are literally hundreds of free modules for Python, which means you pretty much
never have to reinvent any wheels. You just need to know which module to import
into your program.

Now, you may be wondering where all the modules are located and where you can
get them. Well, truthfully, they’re all over the place online. But chances are, you will
never need to go and download one because you already have all the most widely
used modules in the world. You have them because they came along with Anaconda
when you downloaded and installed that. To see for yourself, follow these steps:

1. Open Anaconda in the usual manner on your computer.

2. Click Environments in the left column.
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FIGURE 3-4:
Installed
modules.

Those things you see to the right are actually Python modules that are already
installed on your computer and ready for you to import and use as needed. (See
Figure 3-4.) As you scroll down through the names, you’ll see that you already
have a ton of them. In the right column, you even get to see which version of the
module you have.
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You may also notice that some of the version numbers in the right column are col-
ored and have an arrow showing. These represent modules that may have a more
recent version available for you to download. As with programming languages,
modules evolve over time and version as their authors improve things and add
new capabilities. You’re not required to always have the latest version, though. If
the version you have is working, you can stick with that.

One of many nice things about Anaconda is that in order to get the latest version,
you don’t have to do any weird pip commands, as many older Python tutorials
tell you to do. Instead, just click the arrow or version number of the module you
want to download. In fact, you can click as many as you want. Then click Apply at
the bottom-right. Anaconda does all the dirty work of finding the current module,
determining whether there actually is a newer version available, and then down-
loading that version, if it’s available.

When all the downloads are done, you’ll see a dialog box like the one shown in
Figure 3-5. If no names are listed, then that means all the selected modules are
actually up-to-date so you can just click Cancel and then click Home in the left
pane to return to Anaconda’s home page. If, on the other hand, you do see some
names listed under The Following Packages Will Be Modified, click Apply to install
the latest versions.
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Update Packages

The Following packages will be maodified:

FIGURE 3-5: Allrequested packages already installed.

All our packages

are installed and Cancel
up-to-date.

Syntax for importing modules

As we already mentioned, in your own Python code, you must import a module
before you can access its capabilities. The syntax for doing so is

import modulename [as alias]
When you see such a chart, always remember four things:

¥ The code is case-sensitive, meaning you must type import and as using all
lowercase letters, as shown. It won't work if you use uppercase letters.

¥ Anything in italics is a placeholder for specific information that you'll supply
in your own code. For example, there are dozens of modules available to you.
In your code, you must replace modulename with the exact name of the
module you want to import.

¥ Anything in square brackets is optional, meaning you can type the command
with or without that part.

3 You never type the square brackets in your code because they are not part
of the Python language. They are used only to indicate optional parts in the
syntax.

You can type the import any place you type Python code: the Python command
prompt (>>>), in a .py file, or in a Jupyter notebook. In a .py file you should always
put the import statements first, so their capabilities are available to the rest of
the code.
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Using an alias with modules

As mentioned in the previous section, you can assign an alias, a “nickname,” to
any module you import just by following the module name with a space, the word
as, and then a name of your own choosing. This is usually a short name that’s
easy to type and remember, so you don’t have to type the long name every time
you want to access the module’s capabilities.

For example, instead of typing import random to import that module, we could
import it and give it a nickname like rnd, which is shorter:

import random as rnd

Then, in subsequent code, you wouldn’t use the full name, random, to refer to the
module. Instead, you’d use the short name, rnd, as in the example below:

answer = rnd.randint(1,8)

It may not seem like a big deal in this short example. But you may come across
some modules that have lengthy names, and your code requires referring to that
module in many different places. Having the alias name available lets you type
just that short name, you don’t need to type the full name.

In previous chapters, we promised lots of hands-on in this book. Telling you all
these facts without a lot of guided hands-on practice amounts may seem like
cheating, then. We’ve done so, however, because these bits of background knowl-
edge will help you make sense of things as you learn Python, and should help with
seeing the big picture and remembering things. But now, without any further ado,
it’s time to really apply all you’ve learned so far and start getting your hands dirty
with some real Python code. See you in the next chapter.
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IN THIS CHAPTER

» Open the Python app file

» Typing and using Python comments
» Understanding Python data types
» Doing work with Python operators
» Creating and using variables

» What syntax is and why it matters

» Putting code together

Chapter 4

Building Your First
Python Application

o you want to build an application in Python, huh? Whether you want to code

a website, analyze data, or create a script for automating something, this

chapter gives you all the basics you need to get started on your journey. Most
people use programming languages like Python to create application programs,
which are often referred to as just applications or just programs or even apps for
short. To create apps, you need to know how to write code inside a code editor.
You also need to start learning the language (Python, in this book) in which you’ll
be creating those apps.

Like any language, you need to understand the individual words so that you can
start building sentences and, finally, the blocks of code that will enable your app
to work. First, we walk you through creating an app file in which you create your
code. You then learn all about the various data types, operators, and variables that
are the words of the Python language, and then Python syntax. Along the way, you
see how to save your app, catch mistakes with linting, and even how to comment
your code so that you and others can understand how you built it and why.

Are you ready?
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As we mentioned in the preceding chapters, we’ll be using the ever-popular Visual
Studio Code (VS Code) editor in this book to learn Python and to create Python
apps. Here we assume you’ve already set up your learning/development environ-
ment as described in this chapter, and know how to open the main tools, Ana-
conda Navigator and VS Code. To follow along hands-on in this chapter, start with
these steps:

1.
2.

3.
4.

Open Anaconda Navigator and launch VS Code from there.

If your Python 3 workspace doesn’t open automatically, choose
File > Open Workspace from the VS Code menu and open the Python 3
workspace you created in Chapter 2.

Click the hello. py file you created in the previous chapter.

Select all the text on the first line and delete it, so we can start from
scratch here.

At this point, you should have hello.py open in the editor as shown in Figure 4-1.
If you still have any other tabs open from before, close those now by clicking the
X in each.

FIGURE 4-1:
Thehello.py
file, open for
editing in

VS Code.

% hello.py x
4 OPEN EDITORS 1
% & hello.py
4 PYTHON 3 (WINDOWS) (WORKSPACE)
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Typing and Using Python Comments

Before you type any code, let’s start with a programmer’s comment. A program-
mer’s comment (usually called a comment for short) is text in the program that
does nothing. Which brings up the question . . .” If it doesn’t do anything, then
why type it in?” As a learner, you can use comments in your code as notes to your-
self about what the code is doing. These can help a lot when you’re first learning.

Comments in code aren’t strictly for beginners. When working in teams, profes-
sionals often use comments to explain to team members what their code is doing.
Developers will also put comments in their code as notes to themselves, so that if
they review the code in the future, they can refer to their own notes for remind-
ers on why they did something in the code. Because a comment isn’t code, your
wording can be anything you want. However, to be identified as a comment, the
text must

¥ Start with a pound sign

3 Or be enclosed in triple quotation marks

If it’s a short comment (if it doesn’t extend to two or more lines), the leading
pound sign is sufficient. Often you’ll see that pound sign followed by a space, as
in the example below, but that space is optional:

# This is a Python comment

To type a Python comment into your own code

1. click next to the 1in VS Code under the hello.py tab and type # Thisis a
Python comment in my first Python app.

2. Press Enter.

The comment you typed appears on line 1 as in Figure 4-2. The comment text
will be green if you're using the default color theme. You'll notice that the
blinking cursor is now on line 2.

Although you won’t use multiline comments just yet, be aware that you can type
longer multiline comments in Python by enclosing them in triple quotation marks.
These larger comments are sometimes called docstrings and often appear at the top
of a Python module, function class, or method definition, which are app building
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blocks you will learn about a little later in this book. It isn’t necessary to type one
right now, but here’s an example of what one may look like in Python code:

"""This is a multiline comment in Python

This type of comment is sometimes called a docstring.

A docstring starts with three double-quotation marks (""") and also ends with
three double quotation marks.

M) File Edit Selection View Go Debug Terminal Help hello.py - Python 3
lj\l EXPLORER hellopy x

4 OPEN EDITORS 1 # This is a Python comment in my first Python app.
p % @ hello.py 2

4 PYTHON 3 (WINDOWS) (WORKSPACE)

FIGURE 4-2:
A commentin
hello.py.

In VS Code, comments are usually colored differently than code. Short comments
that start with # are green, whereas docstrings are brown, to help them stand out
from the actual Python code that runs when you run the app.

In case you’re wondering, there is no limit to how many comments you can
put in your code. If you're waiting for something to happen after you type a
comment . . . don’t. When you’re working in an editor like this, code doesn’t do
anything until you run it. Right now, all we have is a comment, so even if we did
run this code, nothing would happen because code is for human readers, not com-
puters. Before you go hands-on and start typing actual code, we need to start with
the absolute basics, which would be.. . .

Understanding Python Data Types

You deal with written information all the time and probably don’t think about
the difference between numbers and text (that is, letters and words). But there’s
a big difference between numbers and text in a computer because with numbers,
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you can do arithmetic (add, subtract, multiple, divide). For example, everybody
knows that 1+1 = 2. The same doesn’t apply to letters and words. The expression
A+A doesn’t necessary equal B or AA or anything else because unlike numbers,
letters and words aren’t quantities. You can buy 12 apples at the store, because 12
is a quantity, a number — a scalar value in programming jargon. You can’t really
buy a snorkel apples because a snorkel is a thing, it’s not a quantity, number, or
scalar value.

Numbers

Numbers in Python must start with a number digit, (0-9); a dot (period), which
is a decimal point; or a hyphen (-) used as a negative sign for negative numbers.
A number can contain only one decimal point. It should contain no letters, spaces,
dollar signs, or anything else that isn’t part of a normal number. Table 4-1 shows
example of good and bad Python numbers.

TABLE 4-1 Examples of Good and Bad Python Numbers
Number Okay? Reason
1 Good A whole number (integer)
1.1 Good A number with a decimal point
1234567.89 Good A large number with a decimal point and no commas
2 Good A negative number, as indicated by the starting hyphen
.99 Good A number that starts with a decimal point because it's less than one.
$1.99 Bad Contains a $
12,345.67 Bad Contains a comma
1101 3232 Bad Contains a space
91740-3384 Bad Contains a hyphen
123-45-6789 Bad Contains two hyphens
123 Oak Tree Lane Bad Contains spaces and words
(267)555-1234 Bad Contain parentheses and hyphens
127.0.0.1 Bad Only one decimal point is allowed

Q

TIP

If you’re worried that the number rules won’t let you work with dollar amounts,
zip codes, addresses or anything else, stop worrying. You can store and work with
all kinds of information, as you’ll see shortly.
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The vast majority of numbers you use will probably match one of the first four
examples of good numbers. However, if you happen to be looking at code used for
more advanced scientific or mathematical applications, you may occasionally see
numbers that contain the letter e or the letter j. That’s because Python actually
supports three different types of numbers, as discussed in the sections that follow.

Integers

An integer is any whole number, positive or negative. There is no limit to its size.
Numbers like 0, -1, and 999999999999999 are all perfectly valid integers. From
your perspective, an integer is just any valid number that doesn’t contain a deci-
mal point.

Floats

A floating point number, often called a float for short, is just any valid num-
ber that contains a decimal point. Again, there is no size limit, 1.1 and -1.1 and
123456.789012345 are all perfectly valid floats.

If you happen to work with very large scientific numbers, you can put an e in a
number to indicate the power of 10. For example, 234€1000 is a valid number, and
will be treated as a float even if there’s no decimal point. If you’re familiar with
scientific notation, you know 234e3 is 234,000 (replace the e3 with 3 zeroes). If
you’re not familiar with scientific notation, don’t worry about it. If you’re not
using it in your day-to-day work now, chances are you’ll never need it in Python
either.

Complex numbers

Just about any kind of number can be expressed as an integer or float, so being
familiar with those is sufficient for just about everyone. Though in the interest
of being accurate we should point out that Python also supports complex numbers.
These bizarre little charmers always end with the letter j, which is the imaginary
part of the number. If you have absolutely no idea what we’re talking about, then
you’re a normal person because only people who are really “out there” in math
land care about these. If you’ve never heard of them before now, chances are you
won’t be using them in your computer work or Python programming.

Words (strings)

Strings are sort of the opposite of numbers. With numbers, you can add, subtract,
multiply, and divide because the numbers represent quantities. Strings are for
just about everything else. Names, addresses, and all other kinds of text you see
every day would be a string in Python (and for computers in general). It’s called
a string because it’s a string of characters (letters, spaces, punctuation marks,
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maybe some numbers). To us, a string usually has some meaning, like a person’s
name or address, but computers don’t have eyes to see with or brains to think
with or any awareness that humans even exist, so if it’s not something on which
you can do arithmetic, it’s just a string of characters.

Unlike numbers, a string must always be enclosed in quotation marks. You can use
either double quotation marks (“) or singles (‘). All the following are valid strings:

"Hi there, I am a string"
'Hello world'
"1283 Oak Tree Lane"

"(267)555-1234"
"18901-3384"

Notice that it’s perfectly fine to use numeric characters (0-9) as well as hyphens
and dots in strings. Each is still a string because it’s enclosed in quotation marks.

A word of caution. If a string contains an apostrophe (single quote), then the
whole string should be enclosed in double quotation marks like this:

"Mary's dog said Woof"

The double quotation marks are necessary because there’s no confusion about
where the string starts and ends. If you instead used single quotes, like this:

'Mary's dog said Woof'

... the computer would be too dumb to get that right. It would see the first single
quote as the start of the string, the second one (after Mary) as the end of the
string, and then it wouldn’t know what to do with the rest of the stuff, and your
app wouldn’t run correctly.

Similarly, if the string contains double-quotation makes, then the whole thing
should be enclosed in single quotation marks to avoid confusion. For example:

'The dog of Mary said "Woof".'

So the first single quotation mark starts the string, the second one ends it, and
the double quotation marks cause no confusion because they’re inside that string.

So what if we have a string that contains both single and double quotation marks,
like this?:

Mary's dog said "Woof".
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This deserves a resounding hmm. Fortunately, the creators of Python realized this
sort of thing can happen, so they came up with an escape. In fact, the things you
use are called escape characters because, in a sense, they allow you to escape (avoid)
the “special meaning” of a character like a single or double quotation mark. To
escape a character, just precede it with a backslash (\). Make sure you use a back-
slash (the one that leans back toward the previous character, like this \) or it won’t
work right.

Using that last example, we could enclose the whole thing in single quotation
marks, and then escape the apostrophe (which is the same character) by preced-
ing it with a backslash, like this:

'Mary\'s dog said "Woof".'

Or, we could enclose the whole thing in double quotation marks, and escape the
quotation marks embedded with the string, like this:

"Mary's dog said \"Woof\"."

Another common use of the backslash is to add a line break to end a line, on the
screen where a user is viewing it (the user being anybody who uses some app you
wrote). For example, this string

"The old pond\nA frog jumped in, \nKerplunk!"

.. would look like this when displayed to a user:

The old pond
A frog jumped in,
Kerplunk!

. . because each \n would be converted to a line break, ending the line there:

True/false Booleans

There is a third data type in Python that isn’t exactly a number, or a string. It’s
called a Boolean (named after a mathematician named George Boole), and it can
be one of two values: either True or False. It may seem a little odd to have a data
type for something that can only be True or False. However, because of the way
computers do their work, it’s actually efficient to make True/False its own data
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type. A single bit, which is the smallest unit of storage in a computer, is all that’s
required to store a value that can only be True or False.

In Python code, people store True or False values in variables (placeholders in code
that we discuss later in this chapter) using a format similar to this:

x = True

... or perhaps this:

X = False

You know True and False are Boolean here because they’re not enclosed in quota-
tion marks (as a string would be), and they’re not numbers. Also, the initial cap is
required. In other words, the first letter has to be capitalized and all the remaining
letters after that have to be lowercase.

Doing Work with Python Operators

You use computers in a couple of ways. One way is to simply store information, like
a file cabinet but without any paper. As we discussed in the previous section, with
Python and for computers in general it helps to think of information as being one
of the following data types: number, string, or Boolean. You also use computers
to operate on that information, meaning to do any necessary math or comparisons
or searches or whatever to help you find information and organize it in a way that
makes sense to you.

Python offers many different operators for working with and comparing types of
information. Here we just summarize them all for future reference, without going
into great detail. Whether you use an operator in your own work depends on the
types of apps you develop. For now, it’s sufficient just to be aware that they’re
available.

Arithmetic operators

As the name implies, arithmetic operators are for doing arithmetic; addition, sub-
traction, multiplication, division, and others. Table 4-2 lists Python’s arithmetic
operators.
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TABLE 4-2

Python’s Arithmetic Operators

Operator Description Example
+ Addition 1T+1=2
- Subtraction 10-1=9
* Multiplication 3*5=15
/ Division 10/5=2
% Modulus (remainder after division) 11%5=1
i Exponent 3**2=9
/! Floor division 11//5=2

The first four items in the table are the same as you learned in elementary school.
The last three are a little more advanced so we’ll explain them here:

¥ The modulus is the remainder after division. So, for example, 11 % 5is 1
because if you divide 11 by 2 you get 5 remainder 1. That 1 is the modulus
(sometimes called the modulo).

3 The exponent is ** because you can't type a small raised number in code. But
it just means “raised to the power of” in the sense that 3**2 is 32 or 3 squared,
which is 3*3 or 9. And of course 3**4 would be 3*3*3*3 or 81.

3 Floor division, indicated by //, is integer division in that anything after the
decimal point is truncated (ignored). The term truncated in this sense means
“cut off,” without any rounding. For example, in regular division 9/5 is 1.8.
But 9//5 is just 1 because the .8 is just chopped off, it doesn't even round
upthe1toa2.

Comparison operators

Computers can make decisions as part of doing their work. But these decisions are
not “judgement call” decisions or anything “human” like that. They are decisions
based on absolute facts based on comparisons. The operators Python offers to help
you write code that makes decisions are listed in Table 4-3.

The first few are self-explanatory, so we won’t go into detail there. The last two
are tricky because they concern Python objects, which we haven’t talked about yet.
Talking about Python objects right now would be a big digression, so if you’re
at all confused about any operators right now, don’t worry about it. For now, we
just want to show them so that in case you’re ever looking at other people’s code,
you’ll have some sense of what they mean.
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TABLE 4-3

TABLE 4-4

Python Comparison Operators

Operator Meaning

< Less than

<= Less than or equal to

> Greater than

>= Greater than or equal to
== Equal to

= Not equal to

is Object identity

is not Negated object identity

Boolean operators

The Boolean operators work with Boolean values (True or False) and are used to
determine if one or more things is True or False. Table 4-4 summarizes the Bool-
ean operators.

Python Boolean Operators

Operator Code Example What It Determines
or X or y Either x ory is true
and x and y Both x and y are true
not not x x is not full

Python style guide recommends always putting whitespace around operators. In
other words, you want to use the spacebar on the keyboard to put a space before
the operator, then type the operator, then add another space before continuing
the line of code. Here is a somewhat simple example. We know you’re not familiar
with coding just yet so don’t worry too much about the exact meaning of the code.
Instead, notice the spaces around the = and > (greater than) operators.

num = 10
if num > ©:

print("Positive number")
else:

print("Negative number")
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The first line stores the number 10 in a variable named num. Then the if checks
to see whether num is greater than (>) o. If it is, the program prints Positive
number. Otherwise, it prints Negative number. So, let’s say you change the first
line of the program to this:

num = -1

If you make that change and run the program again, it prints Negative number
because -1 is a negative number.

We used num as a sample variable name in this example so we could show you
some operators with space around them. Of course, we haven’t told you what
variables are, so that part of the example may have left you scratching your head.
We’ll clear up that part of this business next.

Creating and Using Variables

FIGURE 4-3:

The user's name
and “Member
since” date

on Amazon's
home page.

Variables are a big part of Python and all computer programming languages.
A variable is simply a placeholder for information that may vary (change). For
example, when you browse Amazon today, you can see your name and “member
since” date appear on their home page, as shown in Figure 4-3.

R E SEE SOMETHING NEW, EVERY DAY. =2~} @

@ Deliver to Alan EN Hello, Alan
Buy Again  Browsing History ~ @ ~ Accof\nt&Lists - Orders Prime ~

Stock up
before you head off
Shop Off to College

Hi, Alan Recently viewed Deal of the Day

Customer since 1996

o < e i

72  BOOK 1 Getting Started with Python



Certainly not everyone who goes to Amazon that day is named Alan and has been
a member since 1996. Other people must be seeing other stuff there. But Amazon
certainly can’t make a custom home page for every one of its millions of users. So
most of what’s on that page is probably literal — meaning everybody who views
the page sees the same stuff. Only the information that changes depending on
who is viewing the page is stored as a variable (that is, only the information that
is variable). A variable, in Python, is simply a storage place for information that
can change at any time. But in your code it’s represented by a variable name rather
than a place.

Here is another way to think of it. Anytime you buy one or more of some product,
the extended price is the unit price times the number of items you bought. In other
words

Quantity * Unit Price = Extended Price

You can consider Quantity and Unit Price to be variables, because no matter what
numbers you plug in for Quantity and Unit Price, you get the correct extended
price. For example, if you buy 3 turtle doves for $1.00 apiece, your extended price
is $3.00 (3 * $1.00). If you buy two dozen roses for $1.50 apiece, the extended price
is $36 because 1.5 * 24 is 36.

So, if you consider Quantity and Unit Price to be variables in which you can store
numbers, you get the correct extended price when you multiple those two num-
bers no matter what numbers you use to replace Quantity and Unit Price.

Creating valid variable names

In our explanation of what a variable is we used names like Quantity and Unit
Price, and this is certainly fine for a general example. Those are names we just
made up. In Python, you can also make up your own variable names. But the rules
are more stringent than when making them up in plain English. Python variable
names have to conform to certain rules to be recognized as variable names. The
rules are

¥ The variable name must start with a letter or underscore ().
¥ After the first letter you can use letters, numbers, or underscores.

¥ Variable names are case-sensitive, so once you make up a name, any other
reference to that variable must use the same uppercase and lowercase letters
as the name you originally made up.

¥ Variable names cannot be enclosed in, or contain, single or double quotation
marks.
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3 PEP 8 style conventions recommend using only lowercase letters in variable
names, use an underscore to separate multiple words in the variable name.

PEP 8, which we mentioned in previous chapters, is a style guide for writing code,
rather than strict must-follow rules. So you often see variable names that don’t
conform to that last style. Camel caps formatting — whereby the first letter is
made lowercase and new words are capitalized instead of separated by spaces — is
pretty common, even in Python. For example, extendedPrice or unitPrice are
Camel caps terms that are both technically valid and will not make your program
fail. But experienced Python purists sometimes get that “disgusted” look on their
face when they see names like these in you code. They would prefer you stick
with the PEP 8 style guidelines, which recommend using extended_price and
unit_price as your variable names, on the grounds that the PEP 8 syntax is more
readable for human programmers.

Creating variables in code

To create a variable, you use the syntax (order of things) as follows:

variablename = value

As mentioned, the variablename is the name you make up. You can use x or y,
like people often do in math, but in larger programs, it’s a good idea to give your
variables more meaningful names, like quantity or unit_price or sales_tax or
user_name, so that you can always remember what you’re storing in the variable.

The value is whatever you want to store in the variable. It can be a number, a
string, or a Boolean True or False value.

The = sign in the assignment operator is so named because it assigns the value (on
the right) to the variable (on the left). For example, here . . .

x = 10

... we are storing the number 10 in a variable named x. Or, in other words, we’re
assigning the value 10 to the variable named x.

Here . ..

user_name = "Alan"

We’re putting the string Alan in a variable named username.
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Manipulating variables

Much of computer programming revolves around storing values in variables and
manipulating that information with operators. Let’s go hands-on and try some
simple examples just to get the hang of it. If you still have VS Code open with that
one comment showing, follow these steps in the VS Code editor:

1. under the line that reads # This is a Python comment in my first Python
app., type this comment # This variable contains an integer.

Press Enter, type quantity = 10 (don’t forget to put a space before and
after the = sign), and press Enter.

. Type # This variable contains a float and press Enter again.

Type unit_price = 1.99 and press Enter again (don't type a dollar sign!).

Type # This variable contains the result of multiplying quantity times unit price
and press Enter.

Type extended_price = quantity * unit_price (again with spaces around the
operators) and press Enter.

Type # Show the results and press Enter.

N O Uuhsw N

. Type print(extended_price) and press Enter.

Your Python app creates some variables, stores some value in them, and even cal-
culates a new value, extended_price, based on the contents of the quantity and
unit_price variables. The very last line displays the contents of the extended-
price variable on the screen. Remember, the comments don’t actually do anything
in the program as it’s running. The comments are just notes to yourself about
what’s going on in the program.

Figure 4-4 shows how things should look now. If you made any errors, you may
see some red wavy lines near where there is an error, or possibly green wavy lines
if it’s just a stylistic error such as an extra space or an omitted Enter at the end of
a line. If yours does have errors, make sure that you understand that when typing
code, you have to be accurate. You can’t type something that looks sorta like what
you were supposed to type. When texting to humans, you can make all kinds of
typographical errors and your human recipient can usually figure out what you
meant based on the context of the message. But computers don’t have eyes or
brains or any concept of “context,” and so they will generally just not work prop-
erly if there are errors in your code.

In other words, if the code is wrong, it won’t work when you run it. It’s as simple
as that, no exception.
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FIGURE 4-4:
Your first
Python app
typed into
VS Code.

FIGURE 4-5:
Right-click a .py
file and choose
Run Python File

in Terminal.

® hellopy %

# This is a Python comment in my first Python app.

# This variable contains an integer

quantity = 18

# This variable contains a float

unit_price = 1.99

# This variable contains the result of multiplying quantity times unit price
extended_price = quantity * unit_price

# Show the results

print(extended_price)

© 000 W T AW e

i

Saving your work

Typing code is like typing other documents on a computer. If you don’t save your
work, you may not have it the next time you sit down at your computer and go
looking for it. So if you haven’t enabled Auto Save on the File menu, as discussed
in previous chapters, choose File, then choose Save.

Running your Python app in VS Code

Now we can run the app and see if it works. And an easy way to do that is to right-
click the hello.py filename in the Explorer bar and choose Running a Python app
in VS Code is easy. Just right-click the file’s name (hello.py, in this example) and
choose Run Python File in Terminal as shown in Figure 4-5.

EXPLORER ® hellopy %

# This is a Python commd
# This variable containg

4 OPEN EDITORS

% & hello.py
4 PYTHON 3 (WINDOWS) (WORKSPACE) quantity = 18
Py
S ckytan unit_price = 1.99
B vscode # This variable containg

Jupyter Notebooks

e I“eHc‘py{b

extended_price = quantif

1

2

3

4 # This variable containg
5

[

7

3 # Show the results

Open to the Side Cirl+Enter ~ d_Price)
Reveal in Explorer Shift+Alt+R

Open in Terminal
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Copy Ctrl+C
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Copy Relative Path Ctrl+K Ctri+Alt+C
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Debug All Unit Tests
Run All Unit Tests

Run Python File in Terminal
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FIGURE 4-6:
The 19.91is
the output
fromprint
(extended
price) in

the code.

If your code is typed correctly, you should see the result, 19.9, in the Terminal, as
shown in Figure 4-6.

(base) C:\Users\Alan‘\OneDrive‘\AIO Python>C:/ProgramData/Anaconda2/python.exe "c:/Users/Alan/OneDrive/AI0 Python/hello.py”
10.9

(base) C:\Users\Alan\OneDrive\AIO Py:hunﬁﬂ

DEBUG CONSOLE ERMINAL

The result of running the app appears down in the Terminal window. It cer-
tainly doesn’t look like a typical phone, Mac, or Windows app. That’s because
you’re just getting started and so need to keep things simple. The only indication
that the app ran at all is the number 19.9 in the results. This is the output from
print(extendedprice) in the code, and it’s 19.9 because the quantity (10) times
the unit price (1.99) is 19.9.

Suppose your app must calculate the cost of 14 items going for $26.99 each. Can
you think of how to make that happen? You certainly wouldn’t need to write a
whole new app. Instead, in the code you’re working with now, change the value
of the quantity variable from 10 to 14. Change the value of the unitprice variable
to 26.99 (remember, no dollars in your number). Here’s how the code looks with
those changes:

# This is a Python comment in my first Python app.

# This variable contains an integer

quantity = 14

# This variable contains a float

unit_price = 26.99

# This variable contains the the result of multiplying quantity times unit price
extended_price = quantity % unit_price

# Show some results on the screen.

print(extended_price)

Save your work (unless you already turned on AutoSave as mentioned earlier in

this chapter). Then run that app with the changes by right-clicking and choosing

Run Python File in Terminal once again . . . just like the first time. The results
are again quite a bit of gobbledygook. But you should see the correct answer,
377.85999999999996, in the Terminal near the bottom of the VS Code window.
It doesn’t round to pennies and it doesn’t even look like a dollar amount. But you
need to learn to crawl before you can learn to pole vault, so for now let’s just be
happy with getting our apps to run.
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What Syntax Is and Why It Matters

78

If you look up the word syntax in the dictionary, you’ll probably see it defined as
something like “the arrangement of words and phrases to create well-formed
sentences in a language.” In programming languages like Python, there really is
no such thing as a well-formed sentence. With code, we generally refer to each
line of code a statement or a line (of code). But the order of words is important, and
there are “words” in the sense that you need a space between each word, just as
you do when typing regular text like this.

Syntax is important in human languages because the order contributes much to
the meaning. For example, compare these three short sentences:

Mary kissed John.
John kissed Mary.
Kissed Mary John.

All three sentences contain the same exact words. But the meanings are very
different. The first two make it clear who kissed whom, and the last one is a little
hard to interpret. Even though they all contain exactly the same words.

Proper syntax in programming languages is every bit as important as it is in
human languages — even more so, in some ways, because when you make a
mistake speaking or writing to someone, that other person can usually figure out
what you meant by the context of your words. But computers aren’t nearly that
smart. Computers don’t have brains, can’t “guess your actual meaning” based on
context, and in fact the whole concept of “context” doesn’t even exist for com-
puters. So syntax matters even more when writing code to tell a computer what to
do than it does for human languages.

Looking back at our earliest code, notice that all the lines of actual code (not the
comments, which start with #) follow the syntax. . .

variablename = value

.. . where variablename is some name we made up, and value is something we
are storing in that variable. It works because it’s the proper syntax. If you try to
do it like this . . .

value = variablename

BOOK 1 Getting Started with Python



... it won’t work. For example, this is the correct way to store the value 10 in a
variable named x:

x = 10

It may seem you could also do it this way . . .

10 = x

... but that won’t work in Python. If you run the app with that line in it, nothing
terrible will happen . . . you won’t break anything. But you will get an error mes-
sage that looks something like this:

File ".../AIO Python/hello.py", line 10
10=x

N

SyntaxError: can't assign to literal

The SyntaxError part tells you that Python doesn’t know what to do with that
line of code because you didn’t follow the proper syntax. To fix the error, just
rewrite the line as

x = 10

The Python language consists of lines of code, each one ending with a line break
or semicolon. In other words, this is three lines of Python code:

first_name="Alan"

last_name="Simpson"
print(first_name, last_name)

It would also be perfectly acceptable to us a semicolon wherever instead of a line
break, as below.

first_name="Alan"; last_name="Simpson"
print(first_name, last_name)

Or, if you prefer:

first_name="Alan"; last_name="Simpson"; print(first_name,last_name)
Note that there is no advantage or disadvantage to doing so in terms of how the
code runs. The code runs exactly the same either way. The semicolons are just an

alternative to line breaks that you can use if, for whatever reason, you want to put
a lot of code alone one physical line in your editor.
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Note how our variables’ names are all lowercase, and the words are separated by
an underscore:

first_name

last_name

This is a naming convention used in Python — to use all lowercase letters for vari-
able names with words separated by underscores. But note that a convention is not
the same as a syntax rule. You could name the variables as

FirstName
LastName

This is perfectly okay in Python and doesn’t break any syntax rules. The naming
convention is just there to try to get programmers to follow some basic stylistic
rules that make the code more readable to other programs, which is especially
important when working in programming teams or groups.

So far we’re looked at lines of code. There are also blocks of code or code blocks
where two or more lines of code work together in some manner. Here is an
example:

x = 10
Wit e ==

print("x is zero")
else:

print("x is ",x)
print("All done")

The == (two equal signs) means “is equal to” in Python and is used to compare
values to one another to see if they’re equal. That’s different from just = (one
equal sign), which is the assignment operator for assigning variables.

The first line, x=10, is just a line of code. Next, the i f x == 0 tests to see whether
the x variable contains the number zero. If x does contain zero, then the indented
line (print("x is zero")executes and that’s what you see on the screen. However,
if x does not contain zero, then that indented line is skipped over and the else:
statement executes. The indented line under else: print("x is ",x) executes,
but only if the x doesn’t contain zero. The last line, print("All done!"), executes
no matter what, since it’s not indented.

So, in other words, indentations matter a lot in Python, since only one of the
indented lines above will execute depending on the value in x. We’ll get into the
specifics of using indentations in your code as we progress through the book. For
now, just try to remember that syntax, and indentations are important in Python,
so you must type carefully when writing code.
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FIGURE 4-7:
Touched the
mouse pointer
to a red wavy
underline.

FIGURE 4-8:
Touching the
mouse pointer
to a green wavy
underline.

Next time you run the app, it will run and you won’t get a syntax error for that
line.

If you have linting and PEP 8 enabled in your Workspace settings, as described
in Chapter 3, then you may see red wavy underlines or green wavy underlines on
code that appears to be perfectly okay. Touching the mouse pointer to such an
underline will usually show a message at the mouse pointer indicating what the
problem is, as in Figure 4-7.

hello.p—
[pep8] missing whitespace around operator
on app.

1

2 quantity: int

3 guantity-14

4 # Thil wariable contains a float
5 unit pMice = 26.99

The first part of the message reads:

[pep8] missing whitespace around operator

That’s telling you that this particular error is related to Pep 8 syntax, which says
you should put whitespace around operators.

The second part just tells you that the variable named quantity contains an inte-
ger (int), a whole number. That’s not an error, just information.

To fix the error, put whitespace around the = sign. In other words, us the spacebar
on your keyboard to put a space before the = sign, and then another space after
the = sign.

Now let’s suppose you fix that spacing issue but still see a green wavy underline
under the 14. What’s up with that? Well, to find out, simply click the green wavy
underline and leave the mouse pointer sitting right there until you see an expla-
nation, as in Figure 4-8.

hello.py * S i
N s Thic ie = [pep8] trailing whitespace
2 # This vari 14: int
3 guantity = 1
4 # This \.far‘iélil.e contains a float
5 unit_price = 26.99
6 # This variable contains the result of
7 extended_price = quantity * unit_price
8 # Show the results
9 print(extended_price)
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TIP

This time, the top message shows [pep8] trailing whitespace on top, and 14: int on
the bottom. Again, the bottom part is just informational, telling you that the 14
is stored as an integer. The error is the trailing whitespace. What this means is
that, for whatever reason, there happens to be a blank space after the 14 on that
line. You can’t see it, because it’s just a space. But if you click the end of that line
and press Backspace until the cursor is right up to the 4 in 14, then you will have
eliminated any trailing spaces, and that should clear that error.

Keep in mind that not all red errors are the same and not all green errors are the
same. So don’t make any assumptions. In general, red errors are likely to prevent
the app from running correctly, while green errors are just stylistic errors. But you
won’t know, specifically, what the error is unless you click the wavy underline and
leave the mouse pointer there until you see the message. And the error won’t go
away until you take whatever action is required to fix that error.

If the PeP 8 errors really drive you nuts when trying to learn, remember you
can go into the VS Code Workspace Settings and turn off the Python« Linting:
Pep8Enabled setting so it doesn’t check your code so aggressively.

Putting Code Together

82

The exercises you’ve just completed explain how to type, save, run, change,
and save again, run an app again after making your changes. All those different
things define what you’ll be doing with any kind of software development in any
language. So you want to practice them often until they become second nature to
you. But don’t worry, that doesn’t mean you have to do this one chapter over and
over again to get the hang of it. You’ll be using all these same skills throughout
this book as you work your way from absolute beginner to hot-shot twenty-first
century Python developer.
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IN THIS CHAPTER

» Mastering whole numbers

» Juggling numbers with decimal points
» Simplifying strings
» Conquering Boolean true/false

» Uncovering dates and times

Chapter 1

Working with Numbers,
Text, and Dates

omputers in general, and certainly Python, deal with information in

ways that are different from what you may be used to in your everyday

life. This takes some getting used to. In the computer world, numbers are
numbers you can add, subtract, multiply, and divide. Python also differentiates
between whole numbers (called integers) and numbers that contain a decimal
point (called floats). Words (textual information like names and addresses) are
stored as strings, which is short for “a string of characters.”

In addition to numbers and strings, there are Boolean values, which can be either
True or False, but nothing else. In real life, we also have to deal with dates and
times, which are yet another type of information. Python doesn’t actually have
any built-in data type for dates and times, but thankfully, a free module you can
import any time works with such information. This chapter is all about taking full
advantage of the various Python data types.
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Calculating Numbers with Functions

FIGURE 1-1:
Trying out the
abs () function.

A function in Python is similar to a function on a calculator, in that you pass some-
thing into the function, and the function passes something back. For example,
most calculators and programming languages have a square root function: You
give it a number, and it gives back the square root of that number.

Python functions generally have the syntax:
variablename = functioname(param,[param])

Because most functions return some value, you typically start by defining a
variable to store what the function returns. Follow that with an = sign and the
function name, followed by a pair of parentheses. Inside the parentheses you may
pass one or more values (called parameters or arguments) to the function.

For example, the abs() function accepts one number and returns the absolute
value of that number. If you’re not a math nerd, this just means if you pass it a
negative number, it returns that same number as a positive number. If you pass
it a positive number, it returns exactly the same number you passed it. In other
words, the abs () function simply converts negative numbers to positive numbers.

As an example, in Figure 1-1 (which you can try out for yourself hands-on in a
Jupyter notebook, the Python prompt, or a .py file in VS Code), I created a vari-
able named x and assigned it the value -4. Then I create a variable named y and
assigned it the absolute value of x using the abs () function. Printing x then shows
its value, -4, which hasn’t changed. Printing y shows 4, the absolute value of x as
returned by the abs() function.

- Jupyter 01 Notebook Last Checkpoint: Last Saturday at 2:20 PM ({autosaved)

Insert Cell Kemel

Widgets Help

& B 4+ ¥ MRun B C W Code v =

In [1]: x = -4
y = abs(x)
print{x)
print{y)

-4
4

Even though a function always returns one value, there are some that accept two
or more values. For example, the round() function takes one number as its first
argument. The second value is the number of decimal places to which you want
to round that number, for example, 2 for two decimal places. In the example in
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Figure 1-2, we created a variable, x, with a whole lot of numbers after the decimal
point. Then we created a variable named y to return that same number rounded to
two decimal places. Then we printed both results.

In [2]: | x = 1.23456789893765432100800000000000000008081
y = round(x,2)
print(x)
FIGURE 1-2: print(y)
Trying out
the round() 1.2345673902876543
function. v
Python has many built-in functions for working with numbers, as shown in
Table 1-1. Some of them may not mean much to you if you’re not into math in a
big way, but don’t let that intimidate you. If you don’t understand what a function
does, chances are it’s not doing something that’s relevant to the kind of work you
do. But if you’re curious, you can always google the word python followed by the
function name for more information. For a more extensive list, google python 3
built-in functions.
TABLE 1-1 Some Built-In Python Functions for Numbers

Built-In Function  Purpose

abs(x) Returns the absolute value of number x (converts negative numbers to positive)

bin(x) Returns a string representing the value of x converted to binary.

float(x) Converts a string or number x to a the float data type

format(x,y) Returns x formatted as directed by format string y. In modern Python you're more

likely to use f-strings, as described later in this chapter
hex(x) Returns a string containing x converted to hexadecimal, prefixed with 0Ox.
int(x) Converts x to the integer data type by truncating (not rounding) the decimal point and
any digits after it.

max(x,y,z ...) Takesanynumber of numeric arguments and returns whichever one is the largest.

min(x,y,z ...)  Takesanynumber of numeric arguments and returns whichever one is the smallest.

oct(x) Converts x to an octal number, prefixed with 0o to indicate octal.

round(x, y) Rounds the number x to y number of decimal places.

str(x) Converts number x to the string data type.

type(x) Returns a string indicating the data type of x.
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FIGURE 1-3:
Playing around
with built-in math
functions at the
Python prompt.

Figure 1-3 shows examples of proper Python syntax for using the built-in math
functions.

| pi=3.14159265358979
x=128
y=-345.678908987
Z=-999.9999
print(abs(z))
print(int(z))
print(int(abs(z)))
print(round(pi,4))
print(bin(x))
print(hex(x))
print(oct(x))
print(max(pi,x,y,z))
print(min{pi,x,y,z})
print(type(pi))
print(type(x))
print(type(str(y)))

999.9999

-299

lele]

3.14186
oebleseacee
Bx3e

80200

128

-999,999%
<class 'float'>
<class "int'>»
<class "str'>

You can also “nest” functions — meaning you can put functions inside of func-
tions. For example, when z = -999.9999, the expression print(int(abs(z)))
prints the integer portion of the absolute value of z, which is 999 (the original
number converted to positive, and then the decimal point and everything to its
right chopped off).

Still More Math Functions

88

The built-in math functions are handy, but there are still others you can import
from the math module. If you need them in an app, put import math near the top
of the .py file or Jupyter cell to make those functions available to the rest of the
code. At the command prompt, you can just enter the command import math
before using those functions at the command prompt.

One of the functions of the math module is the sqrt() function that gets the
square root of a number. Because it’s part of the math module, you cannot use it

without importing the module first. For example, if you enter this:

print(sqrt(81))
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FIGURE 1-4:

Using the sqrt()
function from the
math module.

TABLE 1-2

...you’ll get an error because sqrt () isn’t a built-in function. Even if you do two
commands like this:

import math
print(sqrt(81))

... you still get an error because you’re treating sqrt() as a built-in function.

To use a function from a module, you have to import the module and precede the
function name with the module name and a dot. So let’s say you have some value,
%, and you want the square root. You have to import the math module and use
math.sqrt(x) to get the correct answer, as shown in Figure 1-4.

In [11]: | import math
zZ =81
print(math.sqrt(81))

9.9

Entering that command shows 9.0 as the result, which is indeed the square root
of 81.

The math module offers a lot trigonometric and hyperbolic functions, powers and
logarithms, angular conversions, constants like pi and e. We won’t delve into all
of them since advanced math isn’t all that relevant to most people. You can check
them all out at any time by googling python 3 math module functions. Table 1-2
offers a handful of examples, some of which may prove useful in your own work.

Some Functions from the Python Math Module

Built-In Function Purpose

math.acos(x)

Returns the arc cosine of x in radians.

math.atan(x)

Returns the arc tangent of x, in radians.

math.atan2(y, x) Returns atan(y / x), in radians.

math.ceil(x)

Returns the ceiling of x, the smallest integer greater than or equal to x.

math.cos(x)

Returns the cosine of x radians.

math.degrees(x) Converts angle x from radians to degrees.

math.e

Returns the mathematical constante (2.718281 .. .).

(continued)
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TABLE 1-2 (continued)

Built-In Function Purpose

math.exp(x) Returns e raised to the power x, where e is the base of natural logarithms.

math.factorial(x)  Returns the factorial of x.

math. floor() Returns the floor of x, the largest integer less than or equal to x.

math.isnan(x) Returns True if x is not a number, otherwise returns False.

math.log(x,y) Returns the natural logarithm of x to base y.

math.log2(x) Returns the base-2 logarithm of x.

math.pi Returns the mathematical constant pi (3.141592.. . .).

math.pow(x, y) Returns x raised to the power y.

math.radians(x) Converts angle x from degrees to radians.

math.sin(x) Returns the arc sine of x, in radians.

math.sqrt(x) Takes any number of numeric arguments and returns whichever one is
the smallest.

math.tan(x) Returns the tangent of x radians.

math.tau() Returns the mathematical constant tau (6.283185. . .).

The constants pi, e, and tau are unusual for functions in that you don’t use any
parentheses. As with any function, you can use those functions in expressions
(calculations) or assign their values to variables. Figure 1-5 shows some examples
of using functions from the math module.

In [22]: dmport math

pi = math.pi

e = math.e

tau = math.tau

X 81
7
= -23234.5454
rint(pi)
~int(e)
rint(tau)
rint(math.sqrt(x))
~int(math.factorial(y))
rint(math.floor(z))
rint(math.degrees(y))
‘in:'math.radians(isj\

TTTTTOTOTT NS

FIGURE 1-5: 141502653580703
. .718281828450045
More playing .283185387179586

around with 9.0
s Sa4a

built-in math 33238
functions at the 401.87645659157626

B8.7853981633974483
Python prompt. .

[ )
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Formatting Numbers

FIGURE 1-6:
A super simple
f-string for
formatting.

Over the years Python has offered different methods for getting numbers to display
in formats that are familiar to us humans. For example, we may prefer it dis-
play $1,234.56 rather than 1234.560065950695405695405959. As of version 3.6
of Python, f-strings seem to the fastest, easiest, and most preferred method of
achieving this.

Formatting with f-strings

F-string formatting is relatively simple to do. All you need is a lowercase or
uppercase f followed immediately by some text or expressions enclosed in quota-
tion marks. Something along these lines:

f"Hello {username}"

The f before the first quotation mark tells Python that what follows is a format
string (f-string). Inside the quotation marks, the text, called the literal part, is
displayed literally (exactly as typed in the f-string). Anything in curly braces is
the expression part of the f-string. The expression part is a placeholder for what’s
actually going to show there when the code executes. Inside the curly braces you
can have an expression (a formula to perform some calculation, a variable name, or
a combination of the two). Here is an example:

username = "Alan"
print(f"Hello {username}")

When you run this code, the print function displays the word Hello, followed by
a space, followed by the contents of a variable named username, as in Figure 1-6.

In [24]: username = "Alan"
print(f"Hello {username}

Hello Alan

Here is another example where we have an expression — the formula quantity
times unit_price — inside the curly braces.

unit_price = 49.99

quantity = 30
print(f"Subtotal: ${quantity x unit_price}")
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The output from that, when executed, is:

Subtotal: $1499.7

That $1499.7 isn’t really an ideal way to show dollar amounts. Typically we like
to use commas in the thousands places, and two digits for the pennies, as in the
example below:

Subtotal: $1,499.70

Fortunately, f-strings provide you with the means to do this, as you learn next.

Showing dollar amounts

To get a comma to show in the dollar amount and the pennies to be two digits, you
can use a format string inside the curly braces of an expression in an f-string. The
format string starts with a colon and needs to be placed inside the closing curly
brace, right up against the variable name or the value being shown.

To show commas in thousands places, use a comma in your format string right
after the colon, like this:

Using our current example, this would be:

print(f"Subtotal: ${quantity * unit_price:,}")

Executing this statement produced this output:

Subtotal: $1,499.7

To get the pennies to show as two digits, follow the comma with

.2f

The .2f means “two decimal places, fixed” (never any more or less than two
decimal places). So here’s how the code looks to show the number with commas
and two decimal places:

print(f"Subtotal: ${quantity * unit_price:,.2f}")
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Here is how this code looks when executed:

Subtotal: $1,499.70

Perfect! That’s exactly the format we want. So any time you want to show a num-
ber with commas in the thousands places and exactly two digits after the decimal
point, use an f-string with the format string , .2f.

Formatting percent numbers

Now, suppose your app applies sales tax. This app needs to know the sales tax
rate, which should be expressed as a decimal number. So if the sales tax rate is
6.5 percent, then it has to be written as 0.065 (or .065, if you prefer) in your code,
like this:

sales_tax_rate = 0.065

It’s the same amount with or without the leading zero, so just use whichever for-
mat works for you.

This number format is ideal for Python, and you wouldn’t want to mess with
that. But if you want to show that number to a human, simply displaying it with a
print() function shows it exactly as Python stores it:

sales_tax_rate = 0.065
print(f"Sales Tax Rate {sales_tax_rate}")

Sales Tax Rate ©.065

When displaying the sales tax rate for people to read, you’ll probably want to use
the more familiar 6.5% format rather than .065. You can use the same idea as
with fixed numbers (.2f); however, don’t use the f for “fixed numbers.” Instead
replace that with a % sign, like this:

print(f"Sales Tax Rate {sales_tax_rate:.2%}")

Running this code multiples the sales tax rate by 100 and follows it with a % sign,
as you can see in Figure 1-7.

In both of the preceding examples, we used 2 for the number of digits. But of
course you can display any number of digits you want, from zero (none) to what-

ever level of precision you need. For example, using 1.%, as in the following:

print(f"Sales Tax Rate {sales_tax_rate:.1%}")
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FIGURE 1-7:
Formatting a
percentage
number
with .2%.

FIGURE 1-8:

An f-string can be
encased in single,
double, or triple
quotation marks.

Q

TIP

In [36]: sales_tax_rate = 8.865
print(f"Sales Tax Rate {sales_tax_rate:.2%}"

Sales Tax Rate 6.50%

. . shows this output when executed:

Sales Tax Rate 6.5%

Replacing that 1 with a 9, like this

print(f"Sales Tax Rate {sales_tax_rate:.9%}")

... displays the percentage with nine digits after the decimal point.

Sales Tax Rate 6.5000000007%

Your format string doesn’t have to be one short thing inside the parentheses of a
print() function. You can store it to a variable too, then print the variable. The
format string itself is like any other string in that it must be enclosed in single,
double, or triple quotation marks. It doesn’t matter which you use as the outer-
most quotation marks on the format string, the output is the same regardless, as
you can see in the example shown in Figure 1-8.

sales_tax_rate = 8.865
samplel = f'Sales Tax Rate {sales_tax_ rate:.2%}

sample2 = f"Sales Tax Rate {sales tax rate:.2%}"
sample3 = f"""Sales Tax Rate {sales_tax_rate:.2¥}"""
sample4 = f'''Sales Tax Rate {sales_tax_rate:.2%}'"’

print(samplel)
print(sample2)
print(sample3)
print(sample4)

Sales Tax Rate 6.58%
Sales Tax Rate 6.38%
Sales Tax Rate 6.38%
Sales Tax Rate 6.58%

For single and double quotation marks, use the ones on the keyboard key that
shows both kinds of quotation marks. For triple quotation marks, you can use
three of either. Make sure you end the string with exactly the same characters you
used to start the string. For example, all the strings in Figure 1-8 are perfectly
valid code, and they will all be treated the same.

94 BOOK 2 Understanding Python Building Blocks



FIGURE 1-9:
A multiline
f-string
enclosed in
triple
quotation
marks.

Making multiline format strings

If you want to have line breaks in your format strings for multiline output, you
have a couple of choices:

»

»

Use /n: You can use a single-line format string with \n any place you want a
line break. Just make sure you put the \n in the literal portion of the format
string, not inside any curly braces. For example:

userl = "Alberto"
user2 = "Babs"
user3 = "Carlos"

output=f"{user1} \n{user2} \n{user3}"
print(output)

When executed, this code displays:

Alberto
Babs

Carlos

Use triple quotation marks: If you use triple quotation marks around your
format string, then you don't need to use \n. You can just break the line in the
format string wherever you want it to break in the output. For example, look

at the code in Figure 1-9. The format string is in triple quotation marks and
contains multiple line breaks. The output from running the code has line
breaks in all the same places.

As you can see, the output honors the line breaks and even the blank spaces

in the format string. Unfortunately it's not perfect — in real life, we would
right-align all the numbers so all the decimal points line up. All is not lost,
though, because with format strings you can also control the width and
alignments of your output.

unit_price = 49.95

quantity = 32

sales_tax_rate = 8.865

subtotal = quantity * unit_price
sales_tax = sales_tax_rate * subtotal
total = subtotal + sales_tax

output=Ff"""

Subtotal: ${subtotal:,.2f}
Sales Tax: ${sales_tax:,.2f}
Total: ${total:,.2f}

print(output)

Subtotal: §1,593.4@
Sales Tax: $163.98
Total: $1,782.30
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FIGURE 1-10:

All dollar
amounts are
right-aligned
within a width of
9 characters (>9).
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Formatting width and alignment

You can also control the width of your output (and the alignment of content within
that width) by following the colon in your f-string with < (for left-aligned), »
(for centered), or > (for right-aligned). Put any of these characters right after the
colon in your format string. For example

1>20
... says “make this output 20 characters wide, with the content right-aligned.”

In the last example in the previous section, we were able to get all the dollar
amounts left-aligned in the output by making then left-aligned in the format
string. But because the numbers aren’t all the same width, they’re not right-
aligned. To get around that, in Figure 1-10 we used > to make each of the dollar
amounts right-align a width of 9. The printed output shows the numbers are cor-
rectly right-aligned.

unit_price = 49.95

quantity = 32

sales_tax_rate - 8.865

subtotal = quantity * unit_price
sales_tax = sales_tax_rate * subtotal
total = subtotal + sales_tax
output=Ff"""

Subtotal: ${subtotal:»9,.2f}

Sales Tax: ${sales_tax:>9,.2f}

Total: ${total:»2,.2f}

print (output)

Subtotal: % 1,598.48
Sales Tax: $  183.98
Total: $ 1,702.30

You may look at Figure 1-10 and wonder why the dollar signs are lined up the way
they are. Why aren’t they aligned right next to their numbers? This is because the
dollar signs are part of the literal string, outside the curly braces. So they aren’t
affected by the >9 inside the curly braces.

Getting around this issue is a little more complicated than you may imagine,
because you can only use the , .2f formatting on a number. You can’t attach a $
to the front of a number unless you change the number to a string . . . but then
it won’t be a number anymore so the ,.2f won’t work. Complicated, however,
doesn’t mean impossible; it just means inconvenient. We can convert each dollar
amount to a string in the current format, stick the dollar sign on that string, and
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REMEMBER

FIGURE 1-11:
All the dollar
amounts neatly
aligned.

then format the width and alignment on this string. For example, here is how we
could do the subtotal variable:

s_subtotal = "$" + f"{subtotal:,.2f}"

The subtotal is a number calculated by multiplying the quantity times the
unit_price. The s"{subtotal:,2f}" formats that number in the fixed two-
decimal-places format with commas in the thousands places, like this:

1,598.40

This is a string rather than a number, because an f-string always produces a
string. The app sticks a dollar sign on the front of that string using "$"+. So you
end up with a string that looks like $1,598.40. We put this in a new variable
named s_subtotal. (We added the leading s_ to remind us that this is the string
equivalent of the subtotal number, not the original number.) Later in the format
string we just give this a width and right-align it to that width using > 9, like this:

Subtotal: {s_subtotal:>9}

When you use + with strings you concatenate (join together) the two strings. The +
only does addition with numbers, not strings.

Figure 1-11 shows the whole kit-and-caboodle, including the output from run-
ning the code. All the numbers are right-aligned with the dollar signs in the usual
place.

# Numerical values

unit_price = 49.95

quantity = 32

sales_tax_rate = @.865

subtotal = gquantity * unit_price
sales_tax = sales_tax_rate * subtotal
total = subtotal + sales_tax

# Format amounts to show as string with leading dollar sign
s_subtotal = "$" + f"{subtotal:,.2f}"

s_sales_tax = "$" + f"{sales_tax:,.2f}"

s_total = "$" + f"{total:,.2f}"

# Output the string with dollar sign already attached
output=Ff"""

Subtotal: {s_subtotal:»9}

Sales Tax: {s_sales_tax:»>8}

Subtotal: {s_total:»9}

print{output)
Subtotal: $£1,59%.48

Sales Tax: $183.98
Subtotal: $£1,782.3@
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Grappling with Weirder Numbers

Most of us deal with simple numbers like quantities and dollar amounts all the
time. If your work requires you to deal with bases other than 10, or with imaginary
numbers, Python has the stuff you need to get the job done. But keep in mind that
you don’t need to learn these things to use Python or any other language. You
would only use these if your actual work (or perhaps homework) requires it. We’ll
start with binary, octal, and hex numbers, which are used frequently in computer
science.

Binary, octal, and hexadecimal numbers

If your work requires dealing with base 2, base 8, or base 16 numbers, you’re in
luck with Python because it has symbols for writing these as well as functions for
converting among them. Table 1-3 shows the three non-decimal bases and the
digits used by each.

TABLE 1-3 Python for Base 2, 8, and 16 Numbers
System Also Called Digits Used Symbol Function
Base 2 Binary 0.1 0b bin()
Base 8 Octal 0,1,234,56,7 0o oct()
Base 16 Hexadecimal or Hex 0,1,2,34,56,7,8,9,AB,CD,EF 0x hex()

In all honesty, most people never have to work with binary, octal, or hexadecimal
numbers. So if all of this is giving you the heebie-jeebies, don’t sweat it. If you
never heard of them before, chances are you’ll never hear of them again after
you’ve completed this section.

If you want more information about the various numbering systems, you can go
to your favorite search engine and search for binary number or octal, or decimal, or

hexadecimal.

TIP
If you do need to work in other numbering systems for computer science home-
work or whatever, you can use the various functions to convert between number-
ing systems. You can do so right at the Python prompt, of course, as well as in an
apps you create. At the prompt, just use the print() function with the conversion
function inside the parentheses, and the number you want to convert inside the
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